CVE-2025-3121 PyTorch torch.jit.jit_module_from_flatbuffer memory corruption

Medium 4.8 Published Updated

Local attackers can exploit memory corruption in PyTorch's JIT module loading to potentially execute code or cause denial of service.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-3121?

CVE-2025-3121 is a medium-severity memory corruption vulnerability in PyTorch, published on 2 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability classified as problematic has been found in PyTorch 2.6.0. Affected is the function torch.jit.jit_module_from_flatbuffer. The manipulation leads to memory corruption. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used.

Weakness: CWE-119

Which versions are affected by CVE-2025-3121?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.

PackageAffectedFixed in
pytorch BitnamiFrom 2.6.02.7.0
torch PyPIAll versions to 2.6.0-NANone

Products include Linuxfoundation Pytorch.

How do I fix CVE-2025-3121?

Upgrade pytorch to 2.7.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2025-3121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3121 exists.

Sources

Also known as BIT-pytorch-2025-3121, DEBIAN-CVE-2025-3121, ECHO-c621-89db-7a9f, GHSA-qcc7-ch57-rh8j, PYSEC-2025-196, UBUNTU-CVE-2025-3121.

Is CVE-2025-3121 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free