# CVE-2025-3121: PyTorch torch.jit.jit_module_from_flatbuffer memory corruption

> Local attackers can exploit memory corruption in PyTorch's JIT module loading to potentially execute code or cause denial of service.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** BIT-pytorch-2025-3121, DEBIAN-CVE-2025-3121, ECHO-c621-89db-7a9f, GHSA-qcc7-ch57-rh8j, PYSEC-2025-196, UBUNTU-CVE-2025-3121

## What is CVE-2025-3121?

CVE-2025-3121 is a medium-severity memory corruption vulnerability in PyTorch, published on 2 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability classified as problematic has been found in PyTorch 2.6.0. Affected is the function torch.jit.jit_module_from_flatbuffer. The manipulation leads to memory corruption. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2025-3121?

2 open source packages ship an affected version, including pytorch and torch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pytorch` | Bitnami | From 2.6.0 | 2.7.0 |
| `torch` | PyPI | All versions to 2.6.0-NA | None |

Products: Linuxfoundation Pytorch.

## How do I fix CVE-2025-3121?

Upgrade pytorch to 2.7.0 or later.

## Is CVE-2025-3121 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3121 exists.

## Other vulnerabilities in PyTorch

- [CVE-2024-48063](https://insights.sbomify.com/CVE-2024-48063/): Deserialization in n/a (critical 9.8)
- [CVE-2022-45907](https://insights.sbomify.com/CVE-2022-45907/): PyTorch vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2025-32434](https://insights.sbomify.com/CVE-2025-32434/): PyTorch: `torch.load` with `weights_only=True` leads to remote code execution (critical 9.3)
- [CVE-2026-24747](https://insights.sbomify.com/CVE-2026-24747/): PyTorch Vulnerable to Remote Code Execution via Untrusted Checkpoint Files (high 8.8)
- [CVE-2024-31583](https://insights.sbomify.com/CVE-2024-31583/): Pytorch use-after-free vulnerability (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3121 and fix it if it is affected.

What it is: CVE-2025-3121 is a medium-severity memory corruption vulnerability in PyTorch, published on 2 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3121 exists.

Affected packages and fixed versions:
- pytorch (Bitnami): affected from 2.6.0; fixed in 2.7.0
- torch (PyPI): affected all versions up to 2.6.0-NA; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3121/ (Markdown: https://insights.sbomify.com/CVE-2025-3121/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3121
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3121
- OSV: https://osv.dev/vulnerability/CVE-2025-3121

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3121/
Summaries are generated and may contain mistakes; the official description above is the record.
