{"answers":{"affected":"2 open source packages ship an affected version, including drupal/obfuscate. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-3130 in the wild and no public exploit code.","fix":"Upgrade drupal/obfuscate to 2.0.1 or later.","what":"CVE-2025-3130 is a medium-severity cross-site scripting vulnerability in Drupal Obfuscate, published on 2 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-3130 and fix it if it is affected.\n\nWhat it is: CVE-2025-3130 is a medium-severity cross-site scripting vulnerability in Drupal Obfuscate, published on 2 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-3130 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/obfuscate (Packagist): affected all versions; fixed in 2.0.1\n- drupal/obfuscate (Packagist): affected all versions; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3130/ (Markdown: https://insights.sbomify.com/CVE-2025-3130/index.md)","id":"CVE-2025-3130","markdown":"https://insights.sbomify.com/CVE-2025-3130/index.md","name":"CVE-2025-3130","record":{"aliases":["DRUPAL-CONTRIB-2025-029","GHSA-hphm-3x7f-g875"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Obfuscate module","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via stored XSS in the Drupal Obfuscate module, potentially compromising user sessions and site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"obfuscate","vendor":"drupal"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Obfuscate allows Stored XSS.This issue affects Obfuscate: from 0.0.0 before 2.0.1.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Obfuscate - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-029","id":"CVE-2025-3130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"ECA: Event - Condition - Action - Critical - Cross site request forgery - SA-CONTRIB-2025-031","id":"CVE-2025-3131"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/obfuscate","purl":null,"source":"GHSA-hphm-3x7f-g875"},{"ecosystem":"Packagist","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/obfuscate","purl":"pkg:composer/drupal/obfuscate","source":"GHSA-hphm-3x7f-g875"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["2.0.1"],"introduced":["0"],"last_affected":[],"package":"drupal/obfuscate","purl":"pkg:composer/drupal/obfuscate?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-029"}],"prev":{"headline":"Access code - Moderately critical - Access bypass - SA-CONTRIB-2025-028","id":"CVE-2025-3129"},"products":["Obfuscate"],"published":"2025-04-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-03","vendors":["Drupal"]},"summary":"Attackers can inject malicious scripts via stored XSS in the Drupal Obfuscate module, potentially compromising user sessions and site integrity.","url":"https://insights.sbomify.com/CVE-2025-3130/"}