CVE-2025-31363 Data exfiltration via AI plugin Jira tool
Authenticated users can exfiltrate data from arbitrary servers via prompt injection in the Mattermost AI plugin's Jira tool due to missing domain restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-31363?
CVE-2025-31363 is a low-severity server-side request forgery vulnerability in Mattermost Mattermost Server, published on 16 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.4.x <= 10.4.2, 10.5.x <= 10.5.0, 9.11.x <= 9.11.9 fail to restrict domains the LLM can request to contact upstream which allows an authenticated user to exfiltrate data from an arbitrary server accessible to the victim via performing a prompt injection in the AI plugin's Jira tool.
Weakness: CWE-1426
Which versions are affected by CVE-2025-31363?
12 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250218121836-2b5275d87136 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0 | 10.4.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.1 |
6 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.1 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.10+incompatible, 10.4.3+incompatible, 10.5.1+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-31363?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250218121836-2b5275d87136, 10.4.3, 10.5.1 or 9.11.10.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-31363 being exploited?
There is no known exploitation of CVE-2025-31363 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9h6j-4ffx-cm84, GO-2025-3622.