# CVE-2025-31476: tarteaucitron.js allows url scheme injection via unfiltered inputs

> High-privilege users can inject malicious JavaScript via insecure URL schemes in tarteaucitron.js, leading to arbitrary code execution and data theft.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 12 Jun 2025
- **Also known as:** DRUPAL-CONTRIB-2025-027, GHSA-p5g4-v748-6fh8

## What is CVE-2025-31476?

CVE-2025-31476 is a medium-severity cross-site scripting vulnerability in AmauriC tarteaucitron.js, published on 7 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

tarteaucitron.js is a compliant and accessible cookie banner. A vulnerability was identified in tarteaucitron.js, allowing a user with high privileges (access to the site's source code or a CMS plugin) to enter a URL containing an insecure scheme such as javascript:alert(). Before the fix, URL validation was insufficient, which could allow arbitrary JavaScript execution if a user clicked on a malicious link. An attacker with high privileges could insert a link exploiting an insecure URL scheme, leading to execution of arbitrary JavaScript code, theft of sensitive data through phishing attacks, or modification of the user interface behavior. This vulnerability is fixed in 1.20.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-31476?

2 open source packages ship an affected version, including tarteaucitronjs. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tarteaucitronjs` | npm | All versions | 1.20.1 |
| `tarteaucitronjs` | npm | All versions | 1.20.1 |
| `drupal/tacjs` | Packagist:https://packages.drupal.org/8 | All versions | 6.7.0 |

Products: Amauri Tarteaucitronjs, Tacjs Project Tacjs.

## How do I fix CVE-2025-31476?

Upgrade tarteaucitronjs to 1.20.1 or later.

## Is CVE-2025-31476 being exploited?

There is no known exploitation of CVE-2025-31476 in the wild and no public exploit code.

## Other vulnerabilities in AmauriC tarteaucitron.js

- [CVE-2025-31138](https://insights.sbomify.com/CVE-2025-31138/): tarteaucitron.js allows UI manipulation via unrestricted CSS injection (medium 5.5)
- [CVE-2025-31475](https://insights.sbomify.com/CVE-2025-31475/): tarteaucitron.js allows prototype pollution via custom text injection (medium 5.5)
- [CVE-2026-22809](https://insights.sbomify.com/CVE-2026-22809/): tarteaucitron.js has Regular Expression Denial of Service (ReDoS) vulnerability (medium 4.4)
- [CVE-2025-48939](https://insights.sbomify.com/CVE-2025-48939/): tarteaucitron.js vulnerable to DOM Clobbering via document.currentScript (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31476 and fix it if it is affected.

What it is: CVE-2025-31476 is a medium-severity cross-site scripting vulnerability in AmauriC tarteaucitron.js, published on 7 Apr 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-31476 in the wild and no public exploit code.

Affected packages and fixed versions:
- tarteaucitronjs (npm): affected all versions; fixed in 1.20.1
- tarteaucitronjs (npm): affected all versions; fixed in 1.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31476/ (Markdown: https://insights.sbomify.com/CVE-2025-31476/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31476
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31476
- OSV: https://osv.dev/vulnerability/CVE-2025-31476

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31476/
Summaries are generated and may contain mistakes; the official description above is the record.
