# CVE-2025-31477: Improper Scope Validation in the open Endpoint of tauri-plugin-shell

> Attackers can achieve remote code execution by abusing improper protocol validation in the Tauri shell plugin's open endpoint.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-c9pr-q8gx-3mgp

## What is CVE-2025-31477?

CVE-2025-31477 is a critical command injection vulnerability in tauri-apps plugins-workspace, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Tauri shell plugin allows access to the system shell. Prior to 2.2.1, the Tauri shell plugin exposes functionality to execute code and open programs on the system. The open endpoint of this plugin is designed to allow open functionality with the system opener (e.g. xdg-open on Linux). This was meant to be restricted to a reasonable number of protocols like https or mailto by default. This default restriction was not functional due to improper validation of the allowed protocols, allowing for potentially dangerous protocols like file://, smb://, or nfs:// and others to be opened by the system registered protocol handler. By passing untrusted user input to the open endpoint these potentially dangerous protocols can be abused to gain remote code execution on the system. This either requires direct exposure of the endpoint to application users or code execution in the frontend of a Tauri application. This vulnerability is fixed in 2.2.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-31477?

4 open source packages ship an affected version, including @tauri-apps/plugin-shell and tauri-plugin-shell. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@tauri-apps/plugin-shell` | npm | All versions | 2.2.1 |
| `@tauri-apps/plugin-shell` | npm | All versions | 2.2.1 |
| `tauri-plugin-shell` | crates.io | All versions | 2.2.1 |
| `tauri-plugin-shell` | crates.io | All versions | 2.2.1 |

Products: Tauri Plugin-Shell.

## How do I fix CVE-2025-31477?

Upgrade @tauri-apps/plugin-shell to 2.2.1 or later.

## Is CVE-2025-31477 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31477 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31477 and fix it if it is affected.

What it is: CVE-2025-31477 is a critical command injection vulnerability in tauri-apps plugins-workspace, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31477 exists.

Affected packages and fixed versions:
- @tauri-apps/plugin-shell (npm): affected all versions; fixed in 2.2.1
- @tauri-apps/plugin-shell (npm): affected all versions; fixed in 2.2.1
- tauri-plugin-shell (crates.io): affected all versions; fixed in 2.2.1
- tauri-plugin-shell (crates.io): affected all versions; fixed in 2.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31477/ (Markdown: https://insights.sbomify.com/CVE-2025-31477/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31477
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31477
- OSV: https://osv.dev/vulnerability/CVE-2025-31477

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31477/
Summaries are generated and may contain mistakes; the official description above is the record.
