# CVE-2025-31483: Stored XSS in Miniflux Media Proxy due to improper Content-Security-Policy configuration

> An attacker can execute cross-site scripting via the media proxy due to weak Content Security Policy settings in Miniflux.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** DEBIAN-CVE-2025-31483, GHSA-cq88-842x-2jhp, GO-2025-3591, UBUNTU-CVE-2025-31483

## What is CVE-2025-31483?

CVE-2025-31483 is a medium-severity cross-site scripting vulnerability in miniflux v2, published on 3 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Miniflux is a feed reader. Due to a weak Content Security Policy on the /proxy/* route, an attacker can bypass the CSP of the media proxy and execute cross-site scripting when opening external images in a new tab/window. To mitigate the vulnerability, the CSP for the media proxy has been changed from default-src 'self' to default-src 'none'; form-action 'none'; sandbox;. This vulnerability is fixed in 2.2.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-31483?

4 open source packages ship an affected version, including miniflux.app/v2 and miniflux.app.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `miniflux.app/v2` | Go | All versions | 2.2.7 |
| `miniflux.app/v2` | Go | All versions | 2.2.7 |
| `miniflux.app/v2` | Go | All versions | 2.2.7 |
| `miniflux.app` | Go | All versions | None |

## How do I fix CVE-2025-31483?

Upgrade miniflux.app/v2 to 2.2.7 or later.

## Is CVE-2025-31483 being exploited?

There is no known exploitation of CVE-2025-31483 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31483 and fix it if it is affected.

What it is: CVE-2025-31483 is a medium-severity cross-site scripting vulnerability in miniflux v2, published on 3 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-31483 in the wild and no public exploit code.

Affected packages and fixed versions:
- miniflux.app/v2 (Go): affected all versions; fixed in 2.2.7
- miniflux.app/v2 (Go): affected all versions; fixed in 2.2.7
- miniflux.app/v2 (Go): affected all versions; fixed in 2.2.7
- miniflux.app (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31483/ (Markdown: https://insights.sbomify.com/CVE-2025-31483/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31483
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31483
- OSV: https://osv.dev/vulnerability/CVE-2025-31483

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31483/
Summaries are generated and may contain mistakes; the official description above is the record.
