# CVE-2025-31485: GraphQL grant on a property might be cached with different objects

> Attackers can bypass GraphQL property access controls due to incorrect cache key generation, potentially reading unauthorized data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-428q-q3vv-3fq3

## What is CVE-2025-31485?

CVE-2025-31485 is a high-severity missing authorization vulnerability in api-platform core, published on 3 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

API Platform Core is a system to create hypermedia-driven REST and GraphQL APIs. Prior to 4.0.22 and 3.4.17, a GraphQL grant on a property might be cached with different objects. The ApiPlatform\GraphQl\Serializer\ItemNormalizer::isCacheKeySafe() method is meant to prevent the caching but the parent::normalize method that is called afterwards still creates the cache key and causes the issue. This vulnerability is fixed in 4.0.22 and 3.4.17.

Weakness: CWE-696 (Incorrect Behavior Order)

## Which versions are affected by CVE-2025-31485?

12 open source packages ship an affected version, including api-platform/core and api-platform/graphql.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `api-platform/core` | Packagist | All versions | 3.4.17 |
| `api-platform/core` | Packagist | All versions | 3.4.17 |
| `api-platform/core` | Packagist | From 4.0.0-alpha.1 | 4.0.22 |
| `api-platform/core` | Packagist | From 4.0.0-alpha.1 | 4.0.22 |
| `api-platform/core` | Packagist | From 4.1.0-alpha.1 | 4.1.5 |
| `api-platform/core` | Packagist | From 4.1.0-alpha.1 | 4.1.5 |
| `api-platform/graphql` | Packagist | All versions | 3.4.17 |
| `api-platform/graphql` | Packagist | All versions | 3.4.17 |
| `api-platform/graphql` | Packagist | From 4.0.0-alpha.1 | 4.0.22 |
| `api-platform/graphql` | Packagist | From 4.0.0-alpha.1 | 4.0.22 |
| `api-platform/graphql` | Packagist | From 4.1.0-alpha.1 | 4.1.5 |
| `api-platform/graphql` | Packagist | From 4.1.0-alpha.1 | 4.1.5 |

## How do I fix CVE-2025-31485?

Upgrade api-platform/core to a fixed version for your release line: 3.4.17, 4.0.22 or 4.1.5.

## Is CVE-2025-31485 being exploited?

There is no known exploitation of CVE-2025-31485 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31485 and fix it if it is affected.

What it is: CVE-2025-31485 is a high-severity missing authorization vulnerability in api-platform core, published on 3 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31485 in the wild and no public exploit code.

Affected packages and fixed versions:
- api-platform/core (Packagist): affected all versions; fixed in 3.4.17
- api-platform/core (Packagist): affected all versions; fixed in 3.4.17
- api-platform/core (Packagist): affected from 4.0.0-alpha.1; fixed in 4.0.22
- api-platform/core (Packagist): affected from 4.0.0-alpha.1; fixed in 4.0.22
- api-platform/core (Packagist): affected from 4.1.0-alpha.1; fixed in 4.1.5
- api-platform/core (Packagist): affected from 4.1.0-alpha.1; fixed in 4.1.5
- api-platform/graphql (Packagist): affected all versions; fixed in 3.4.17
- api-platform/graphql (Packagist): affected all versions; fixed in 3.4.17
- api-platform/graphql (Packagist): affected from 4.0.0-alpha.1; fixed in 4.0.22
- api-platform/graphql (Packagist): affected from 4.0.0-alpha.1; fixed in 4.0.22
- api-platform/graphql (Packagist): affected from 4.1.0-alpha.1; fixed in 4.1.5
- api-platform/graphql (Packagist): affected from 4.1.0-alpha.1; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31485/ (Markdown: https://insights.sbomify.com/CVE-2025-31485/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31485
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31485
- OSV: https://osv.dev/vulnerability/CVE-2025-31485

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31485/
Summaries are generated and may contain mistakes; the official description above is the record.
