# CVE-2025-31487: The XWiki JIRA extension allows data leak through an XXE attack by using a fake JIRA server

> Logged-in users can leak local server files by configuring the JIRA macro to point to a malicious XML server.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-wc53-4255-gw3f

## What is CVE-2025-31487?

CVE-2025-31487 is a high-severity vulnerability in xwiki-contrib jira, published on 3 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The XWiki JIRA extension provides various integration points between XWiki and JIRA (macros, UI, CKEditor plugin). If the JIRA macro is installed, any logged in XWiki user could edit his/her user profile wiki page and use that JIRA macro, specifying a fake JIRA URL that returns an XML specifying a DOCTYPE pointing to a local file on the XWiki server host and displaying that file's content in one of the returned JIRA fields (such as the summary or description for example). The vulnerability has been patched in the JIRA Extension v8.6.5.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2025-31487?

2 open source packages ship an affected version, including org.xwiki.contrib.jira:jira-macro-default.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.contrib.jira:jira-macro-default` | Maven | From 4.2 | 8.5.6 |
| `org.xwiki.contrib.jira:jira-macro-default` | Maven | From 4.2 | 8.5.6 |

## How do I fix CVE-2025-31487?

Upgrade org.xwiki.contrib.jira:jira-macro-default to 8.5.6 or later.

## Is CVE-2025-31487 being exploited?

There is no known exploitation of CVE-2025-31487 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31487 and fix it if it is affected.

What it is: CVE-2025-31487 is a high-severity vulnerability in xwiki-contrib jira, published on 3 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31487 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.contrib.jira:jira-macro-default (Maven): affected from 4.2; fixed in 8.5.6
- org.xwiki.contrib.jira:jira-macro-default (Maven): affected from 4.2; fixed in 8.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31487/ (Markdown: https://insights.sbomify.com/CVE-2025-31487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31487
- OSV: https://osv.dev/vulnerability/CVE-2025-31487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31487/
Summaries are generated and may contain mistakes; the official description above is the record.
