# CVE-2025-31490: AutoGPT allows SSRF due to DNS Rebinding in requests wrapper

> Attackers can bypass SSRF protections via DNS rebinding to access internal resources in AutoGPT.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Apr 2025
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-wvjg-9879-3m7w

## What is CVE-2025-31490?

CVE-2025-31490 is a high-severity server-side request forgery vulnerability in Significant-Gravitas AutoGPT, published on 14 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents that automate complex workflows. Prior to 0.6.1, AutoGPT allows SSRF due to DNS Rebinding in requests wrapper. AutoGPT is built with a wrapper around Python's requests library, hardening the application against SSRF. The code for this wrapper can be found in autogpt_platform/backend/backend/util/request.py. The requested hostname of a URL which is being requested is validated, ensuring that it does not resolve to any local ipv4 or ipv6 addresses. However, this check is not sufficient, as a DNS server may initially respond with a non-blocked address, with a TTL of 0. This means that the initial resolution would appear as a non-blocked address. In this case, validate_url() will return the url as successful. After validate_url() has successfully returned the url, the url is then passed to the real request() function. When the real request() function is called with the validated url, request() will once again resolve the address of the hostname, because the record will not have been cached (due to TTL 0). This resolution may be in the "invalid range". This type of attack is called a "DNS Rebinding Attack". This vulnerability is fixed in 0.6.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-31490?

It affects 1 product.


Products: Agpt Autogpt Platform.

## How do I fix CVE-2025-31490?

No fix has been published for CVE-2025-31490 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-31490 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31490 exists.

## Other vulnerabilities in Significant-Gravitas AutoGPT

- [CVE-2026-26020](https://insights.sbomify.com/CVE-2026-26020/): AutoGPT Affected by Remote Code Execution via Dynamic Module Import in Block Loading (__import__) (critical 9.4)
- [CVE-2025-62615](https://insights.sbomify.com/CVE-2025-62615/): AutoGPT has SSRF vulnerability in ReadRSSFeedBlock (critical 9.3)
- [CVE-2025-62616](https://insights.sbomify.com/CVE-2025-62616/): AutoGPT has SSRF vulnerability in SendDiscordFileBlock (critical 9.3)
- [CVE-2025-1040](https://insights.sbomify.com/CVE-2025-1040/): Server-Side Template Injection (SSTI) in significant-gravitas/autogpt (high 8.8)
- [CVE-2025-32393](https://insights.sbomify.com/CVE-2025-32393/): AutoGPT has a DoS vulnerability in ReadRSSFeedBlock (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31490 and fix it if it is affected.

What it is: CVE-2025-31490 is a high-severity server-side request forgery vulnerability in Significant-Gravitas AutoGPT, published on 14 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31490 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31490/ (Markdown: https://insights.sbomify.com/CVE-2025-31490/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31490
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31490
- OSV: https://osv.dev/vulnerability/CVE-2025-31490

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31490/
Summaries are generated and may contain mistakes; the official description above is the record.
