# CVE-2025-31491: AutoGPT allows leakage of cross-domain cookies and protected headers in requests redirect

> AutoGPT leaks sensitive authentication headers and cookies during cross-domain redirects, exposing credentials to malicious third-party sites.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Apr 2025
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-ggcm-93qg-gfhp

## What is CVE-2025-31491?

CVE-2025-31491 is a high-severity vulnerability in Significant-Gravitas AutoGPT, published on 14 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AutoGPT is a platform that allows users to create, deploy, and manage continuous artificial intelligence agents that automate complex workflows. Prior to 0.6.1, AutoGPT allows of leakage of cross-domain cookies and protected headers in requests redirect. AutoGPT uses a wrapper around the requests python library, located in autogpt_platform/backend/backend/util/request.py. In this wrapper, redirects are specifically NOT followed for the first request. If the wrapper is used with allow_redirects set to True (which is the default), any redirect is not followed by the initial request, but rather re-requested by the wrapper using the new location. However, there is a fundamental flaw in manually re-requesting the new location: it does not account for security-sensitive headers which should not be sent cross-origin, such as the Authorization and Proxy-Authorization header, and cookies. For example in autogpt_platform/backend/backend/blocks/github/_api.py, an Authorization header is set when retrieving data from the GitHub API. However, if GitHub suffers from an open redirect vulnerability (such as the made-up example of https://api.github.com/repos/{owner}/{repo}/issues/comments/{comment_id}/../../../../../redirect/?url=https://joshua.hu/), and the script can be coerced into visiting it with the Authorization header, the GitHub credentials in the Authorization header will be leaked. This allows leaking auth headers and private cookies. This vulnerability is fixed in 0.6.1.

Weakness: CWE-601 (URL Redirection to Untrusted Site), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-31491?

It affects 1 product.


Products: Agpt Autogpt Platform.

## How do I fix CVE-2025-31491?

No fix has been published for CVE-2025-31491 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-31491 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31491 exists.

## Other vulnerabilities in Significant-Gravitas AutoGPT

- [CVE-2026-26020](https://insights.sbomify.com/CVE-2026-26020/): AutoGPT Affected by Remote Code Execution via Dynamic Module Import in Block Loading (__import__) (critical 9.4)
- [CVE-2025-62615](https://insights.sbomify.com/CVE-2025-62615/): AutoGPT has SSRF vulnerability in ReadRSSFeedBlock (critical 9.3)
- [CVE-2025-62616](https://insights.sbomify.com/CVE-2025-62616/): AutoGPT has SSRF vulnerability in SendDiscordFileBlock (critical 9.3)
- [CVE-2025-1040](https://insights.sbomify.com/CVE-2025-1040/): Server-Side Template Injection (SSTI) in significant-gravitas/autogpt (high 8.8)
- [CVE-2025-32393](https://insights.sbomify.com/CVE-2025-32393/): AutoGPT has a DoS vulnerability in ReadRSSFeedBlock (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31491 and fix it if it is affected.

What it is: CVE-2025-31491 is a high-severity vulnerability in Significant-Gravitas AutoGPT, published on 14 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-31491 exists.

Affected product: Significant-Gravitas AutoGPT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31491/ (Markdown: https://insights.sbomify.com/CVE-2025-31491/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31491
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31491
- OSV: https://osv.dev/vulnerability/CVE-2025-31491

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31491/
Summaries are generated and may contain mistakes; the official description above is the record.
