# CVE-2025-31493: Path traversal of collection names during file system lookup

> Attackers can execute arbitrary code and read files via path traversal in dynamic collection names, requiring specific site code patterns.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 May 2025
- **Updated:** 13 May 2025
- **Also known as:** GHSA-x275-h9j4-7p4h

## What is CVE-2025-31493?

CVE-2025-31493 is a medium-severity path traversal vulnerability in getkirby kirby, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Kirby is an open-source content management system. A vulnerability in versions prior to 3.9.8.3, 3.10.1.2, and 4.7.1 affects all Kirby sites that use the `collection()` helper or `$kirby->collection()` method with a dynamic collection name (such as a collection name that depends on request or user data). Sites that only use fixed calls to the `collection()` helper/`$kirby->collection()` method (i.e. calls with a simple string for the collection name) are *not* affected. A missing path traversal check allowed attackers to navigate and access all files on the server that were accessible to the PHP process, including files outside of the collections root or even outside of the Kirby installation. PHP code within such files was executed. Such attacks first require an attack vector in the site code that is caused by dynamic collection names, such as `collection('tags-' . get('tags'))`. It generally also requires knowledge of the site structure and the server's file system by the attacker, although it can be possible to find vulnerable setups through automated methods such as fuzzing. In a vulnerable setup, this could cause damage to the confidentiality and integrity of the server. The problem has been patched in Kirby 3.9.8.3, Kirby 3.10.1.2, and Kirby 4.7.1. In all of the mentioned releases, the maintainers of Kirby have added a check for the collection path that ensures that the resulting path is contained within the configured collections root. Collection paths that point outside of the collections root will not be loaded.

Weakness: CWE-23 (Relative Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-31493?

6 open source packages ship an affected version, including getkirby/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getkirby/cms` | Packagist | All versions | 3.9.8.3 |
| `getkirby/cms` | Packagist | All versions | 3.9.8.3 |
| `getkirby/cms` | Packagist | From 3.10.0 | 3.10.1.2 |
| `getkirby/cms` | Packagist | From 3.10.0 | 3.10.1.2 |
| `getkirby/cms` | Packagist | From 4.0.0 | 4.7.1 |
| `getkirby/cms` | Packagist | From 4.0.0 | 4.7.1 |

Products: Getkirby Kirby.

## How do I fix CVE-2025-31493?

Upgrade getkirby/cms to a fixed version for your release line: 3.9.8.3, 3.10.1.2 or 4.7.1.

## Is CVE-2025-31493 being exploited?

There is no known exploitation of CVE-2025-31493 in the wild and no public exploit code.

## Other vulnerabilities in getkirby kirby

- [CVE-2024-26483](https://insights.sbomify.com/CVE-2024-26483/): Kirby vulnerable to unrestricted file upload of user avatar images (high 8.8)
- [CVE-2024-41964](https://insights.sbomify.com/CVE-2024-41964/): Insufficient permission checks in the language settings in Kirby CMS (high 8.1)
- [CVE-2026-34587](https://insights.sbomify.com/CVE-2026-34587/): Kirby has Server-Side Template Injection (SSTI) via double template resolution in option rendering (high 7.6)
- [CVE-2021-29460](https://insights.sbomify.com/CVE-2021-29460/): Cross-site scripting (XSS) from unsanitized uploaded SVG files (high 7.6)
- [CVE-2023-38489](https://insights.sbomify.com/CVE-2023-38489/): Kirby vulnerable to Insufficient Session Expiration after a password change (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31493 and fix it if it is affected.

What it is: CVE-2025-31493 is a medium-severity path traversal vulnerability in getkirby kirby, published on 13 May 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31493 in the wild and no public exploit code.

Affected packages and fixed versions:
- getkirby/cms (Packagist): affected all versions; fixed in 3.9.8.3
- getkirby/cms (Packagist): affected all versions; fixed in 3.9.8.3
- getkirby/cms (Packagist): affected from 3.10.0; fixed in 3.10.1.2
- getkirby/cms (Packagist): affected from 3.10.0; fixed in 3.10.1.2
- getkirby/cms (Packagist): affected from 4.0.0; fixed in 4.7.1
- getkirby/cms (Packagist): affected from 4.0.0; fixed in 4.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31493/ (Markdown: https://insights.sbomify.com/CVE-2025-31493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31493
- OSV: https://osv.dev/vulnerability/CVE-2025-31493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31493/
Summaries are generated and may contain mistakes; the official description above is the record.
