{"answers":{"affected":"2 open source packages ship an affected version, including apollo-compiler.","exploited":"There is no known exploitation of CVE-2025-31496 in the wild and no public exploit code.","fix":"Upgrade apollo-compiler to 1.27.0 or later.","what":"CVE-2025-31496 is a high-severity denial of service vulnerability in apollographql apollo-rs, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-31496 and fix it if it is affected.\n\nWhat it is: CVE-2025-31496 is a high-severity denial of service vulnerability in apollographql apollo-rs, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-31496 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apollo-compiler (crates.io): affected all versions; fixed in 1.27.0\n- apollo-compiler (crates.io): affected all versions; fixed in 1.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31496/ (Markdown: https://insights.sbomify.com/CVE-2025-31496/index.md)","id":"CVE-2025-31496","markdown":"https://insights.sbomify.com/CVE-2025-31496/index.md","name":"CVE-2025-31496","record":{"aliases":["GHSA-7mpv-9xg6-5r79"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GraphQL compiler library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using apollo-compiler by submitting queries with deeply nested and reused named fragments.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"apollo-compiler is a query-based compiler for the GraphQL query language. Prior to 1.27.0, a vulnerability in Apollo Compiler allowed queries with deeply nested and reused named fragments to be prohibitively expensive to validate. Named fragments were being processed once per fragment spread in some cases during query validation, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service in applications. This vulnerability is fixed in 1.27.0.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"apollo-compiler Named Fragment Processing Vulnerability","id":"CVE-2025-31496","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"TEIGarage XML External Entity (XXE) Injection in Document Conversion Service","id":"CVE-2025-31497"},"packages":[{"ecosystem":"crates.io","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"apollo-compiler","purl":null,"source":"GHSA-7mpv-9xg6-5r79"},{"ecosystem":"crates.io","fixed":["1.27.0"],"introduced":["0"],"last_affected":[],"package":"apollo-compiler","purl":"pkg:cargo/apollo-compiler","source":"GHSA-7mpv-9xg6-5r79"}],"prev":{"headline":"AutoGPT allows cross-user sharing of node execution results through WebSockets API","id":"CVE-2025-31494"},"products":["apollo-rs"],"published":"2025-04-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-08","vendors":["apollographql"]},"summary":"Attackers can cause denial of service in applications using apollo-compiler by submitting queries with deeply nested and reused named fragments.","url":"https://insights.sbomify.com/CVE-2025-31496/"}