# CVE-2025-31496: apollo-compiler Named Fragment Processing Vulnerability

> Attackers can cause denial of service in applications using apollo-compiler by submitting queries with deeply nested and reused named fragments.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-7mpv-9xg6-5r79

## What is CVE-2025-31496?

CVE-2025-31496 is a high-severity denial of service vulnerability in apollographql apollo-rs, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

apollo-compiler is a query-based compiler for the GraphQL query language. Prior to 1.27.0, a vulnerability in Apollo Compiler allowed queries with deeply nested and reused named fragments to be prohibitively expensive to validate. Named fragments were being processed once per fragment spread in some cases during query validation, leading to exponential resource usage when deeply nested and reused fragments were involved. This could lead to excessive resource consumption and denial of service in applications. This vulnerability is fixed in 1.27.0.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-31496?

2 open source packages ship an affected version, including apollo-compiler.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apollo-compiler` | crates.io | All versions | 1.27.0 |
| `apollo-compiler` | crates.io | All versions | 1.27.0 |

## How do I fix CVE-2025-31496?

Upgrade apollo-compiler to 1.27.0 or later.

## Is CVE-2025-31496 being exploited?

There is no known exploitation of CVE-2025-31496 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31496 and fix it if it is affected.

What it is: CVE-2025-31496 is a high-severity denial of service vulnerability in apollographql apollo-rs, published on 7 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31496 in the wild and no public exploit code.

Affected packages and fixed versions:
- apollo-compiler (crates.io): affected all versions; fixed in 1.27.0
- apollo-compiler (crates.io): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31496/ (Markdown: https://insights.sbomify.com/CVE-2025-31496/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31496
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31496
- OSV: https://osv.dev/vulnerability/CVE-2025-31496

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31496/
Summaries are generated and may contain mistakes; the official description above is the record.
