CVE-2025-31499 Jellyfin Vulnerable to Argument Injection in FFmpeg

High 7.6 Published Updated

Attackers can inject FFmpeg arguments via media stream endpoints to write arbitrary files and achieve remote code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-31499?

CVE-2025-31499 is a high-severity command injection vulnerability in jellyfin, published on 15 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jellyfin is an open source self hosted media server. Versions before 10.10.7 are vulnerable to argument injection in FFmpeg. This can be leveraged to possibly achieve remote code execution by anyone with credentials to a low-privileged user. This vulnerability was previously reported in CVE-2023-49096 and patched in version 10.8.13, but the patch can be bypassed. The original fix sanitizes some parameters to make injection impossible, but certain unsanitized parameters can still be used for argument injection. The same unauthenticated endpoints are vulnerable: /Videos/<itemId>/stream and /Videos/<itemId>/stream.<container>, likely alongside similar endpoints in AudioController. This argument injection can be exploited to achieve arbitrary file write, leading to possible remote code execution through the plugin system. While the unauthenticated endpoints are vulnerable, a valid itemId is required for exploitation and any authenticated attacker could easily retrieve a valid itemId to make the exploit work. This vulnerability is patched in version 10.10.7.

Weakness: CWE-88

Which versions are affected by CVE-2025-31499?

It affects 1 product.

Products include Jellyfin Jellyfin.

How do I fix CVE-2025-31499?

No fix has been published for CVE-2025-31499 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2025-31499 being exploited?

There is no known exploitation of CVE-2025-31499 in the wild and no public exploit code.

Sources

Also known as GHSA-2c3c-r7gp-q32m.

Is CVE-2025-31499 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free