# CVE-2025-3153: Concrete CMS version 9 below 9.4.0RC2 and versions below 8.5.20 - CSRF and XSS in Concrete CMS Custom Address attribute

> Attackers with address input privileges can inject scripts via unsanitized address fields, leading to data exposure and modification in Concrete CMS.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Apr 2025
- **Updated:** 3 Apr 2025
- **Also known as:** GHSA-cmm4-p9v2-q453

## What is CVE-2025-3153?

CVE-2025-3153 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Concrete CMS version 9 below 9.4.0RC2 and versions below 8.5.20 are vulnerable to CSRF and XSS in the Concrete CMS Address attribute because addresses are not properly sanitized in the output when a country is not specified.  Attackers are limited to individuals whom a site administrator has granted the ability to fill in an address attribute. It is possible for the attacker to glean limited information from the site but amount and type is restricted by mitigating controls and the level of access of the attacker. Limited data modification is possible. The dashboard page itself could be rendered unavailable. 
The fix only sanitizes new data uploaded post update to Concrete CMS 9.4.0RC2. Existing database entries added before the update will still be “live” if there were successful exploits added under previous versions; a database search is recommended. The Concrete CMS security team gave this vulnerability CVSS v.4.0 score of 5.1  with vector CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L Thanks Myq Larson for reporting.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-3153?

4 open source packages ship an affected version, including concrete5/concrete5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `concrete5/concrete5` | Packagist | All versions | 8.5.20 |
| `concrete5/concrete5` | Packagist | All versions | 8.5.20 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.4.0RC2 |
| `concrete5/concrete5` | Packagist | From 9.0.0 | 9.4.0RC2 |

Products: Concretecms Concrete Cms.

## How do I fix CVE-2025-3153?

Upgrade concrete5/concrete5 to a fixed version for your release line: 8.5.20 or 9.4.0RC2.

## Is CVE-2025-3153 being exploited?

There is no known exploitation of CVE-2025-3153 in the wild and no public exploit code.

## Other vulnerabilities in Concretecms Concrete Cms

- [CVE-2023-48648](https://insights.sbomify.com/CVE-2023-48648/): Concrete CMS allows unauthorized access because directories can be created with insecure permissions (critical 9.8)
- [CVE-2022-21829](https://insights.sbomify.com/CVE-2022-21829/): Code injection in concrete CMS (critical 9.8)
- [CVE-2021-22958](https://insights.sbomify.com/CVE-2021-22958/): Server-Side Request Forgery vulnerability in concrete5 (critical 9.8)
- [CVE-2021-40098](https://insights.sbomify.com/CVE-2021-40098/): Path traversal in n/a (critical 9.8)
- [CVE-2026-8134](https://insights.sbomify.com/CVE-2026-8134/): Concrete CMS Vulnerable to Relative Path Traversal (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3153 and fix it if it is affected.

What it is: CVE-2025-3153 is a medium-severity cross-site scripting vulnerability in Concretecms Concrete Cms, published on 3 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-3153 in the wild and no public exploit code.

Affected packages and fixed versions:
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.20
- concrete5/concrete5 (Packagist): affected all versions; fixed in 8.5.20
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.4.0RC2
- concrete5/concrete5 (Packagist): affected from 9.0.0; fixed in 9.4.0RC2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3153/ (Markdown: https://insights.sbomify.com/CVE-2025-3153/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3153
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3153
- OSV: https://osv.dev/vulnerability/CVE-2025-3153

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3153/
Summaries are generated and may contain mistakes; the official description above is the record.
