CVE-2025-31650 Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame
Attackers can cause denial of service in Apache Tomcat by sending malformed HTTP/2 PRIORITY_UPDATE frames that trigger memory leaks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-31650?
CVE-2025-31650 is a high-severity denial of service vulnerability in Apache Tomcat, published on 28 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service.
This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100.
Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.
Weakness: CWE-459
Which versions are affected by CVE-2025-31650?
17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.10 | 10.1.40 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 10.1.10 | 10.1.40 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M2 | 11.0.6 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 11.0.0-M2 | 11.0.6 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 8.5.0 to 8.5.100 | None |
11 more packages
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.76 | 9.0.104 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 9.0.76 | 9.0.104 |
tomcat Bitnami | From 9.0.76 | 9.0.104, 10.1.40, 11.0.6 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.10 | 10.1.40 |
org.apache.tomcat:tomcat-coyote Maven | From 10.1.10 | 10.1.40 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M2 | 11.0.6 |
org.apache.tomcat:tomcat-coyote Maven | From 11.0.0-M2 | 11.0.6 |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 8.5.0 to 8.5.100 | None |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.76 | 9.0.104 |
org.apache.tomcat:tomcat-coyote Maven | From 9.0.76 | 9.0.104 |
Products include Apache Tomcat.
How do I fix CVE-2025-31650?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.40, 11.0.6 or 9.0.104.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-31650 being exploited?
There is no known exploitation of CVE-2025-31650 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry and 6 proofs of concept on GitHub.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2025-31650, CLEANSTART-2026-SR71382, DEBIAN-CVE-2025-31650, GHSA-3p2h-wqq4-wf4h, MINI-9pcj-gjqc-xv52, MINI-cccq-jpcw-6w4f and 3 more.