# CVE-2025-31650: Apache Tomcat: DoS via malformed HTTP/2 PRIORITY_UPDATE frame

> Attackers can cause denial of service in Apache Tomcat by sending malformed HTTP/2 PRIORITY_UPDATE frames that trigger memory leaks.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-tomcat-2025-31650, CLEANSTART-2026-SR71382, DEBIAN-CVE-2025-31650, GHSA-3p2h-wqq4-wf4h, MINI-9pcj-gjqc-xv52, MINI-cccq-jpcw-6w4f, MINI-jfm4-759q-f32h, ROOT-APP-MAVEN-CVE-2025-31650, UBUNTU-CVE-2025-31650

## What is CVE-2025-31650?

CVE-2025-31650 is a high-severity denial of service vulnerability in Apache Tomcat, published on 28 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service.

This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.90 though 8.5.100.

Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

Weakness: CWE-459 (Incomplete Cleanup)

## Which versions are affected by CVE-2025-31650?

17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-coyote. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.76 | 9.0.104 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.76 | 9.0.104 |
| `tomcat` | Bitnami | From 9.0.76 | 9.0.104, 10.1.40, 11.0.6 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.76 | 9.0.104 |
| `org.apache.tomcat:tomcat-coyote` | Maven | From 9.0.76 | 9.0.104 |

Products: Apache Tomcat.

## How do I fix CVE-2025-31650?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.40, 11.0.6 or 9.0.104.

## Is CVE-2025-31650 being exploited?

There is no known exploitation of CVE-2025-31650 in the wild and no public exploit code.

Public exploit code:

- A tool designed to detect the vulnerability **CVE-2025-31650** in Apache Tomcat (versions 10.1.10 to 10.1.39) (github_poc): https://github.com/absholi7ly/TomcatKiller-CVE-2025-31650
- CVE-2025-31650 PoC (github_poc): https://github.com/tunahantekeoglu/CVE-2025-31650
- https://github.com/sattarbug/Analysis-of-TomcatKiller---CVE-2025-31650-Exploit-Tool (github_poc): https://github.com/sattarbug/Analysis-of-TomcatKiller---CVE-2025-31650-Exploit-Tool
- Apache Tomcat 10.1.39 - Denial of Service (DoS) (exploitdb)
- CVE-2025-31650 (github_poc): https://github.com/assad12341/Dos-exploit-
- https://github.com/obscura-cert/CVE-2025-31650 (github_poc): https://github.com/obscura-cert/CVE-2025-31650

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31650 and fix it if it is affected.

What it is: CVE-2025-31650 is a high-severity denial of service vulnerability in Apache Tomcat, published on 28 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31650 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M2; fixed in 11.0.6
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M2; fixed in 11.0.6
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.76; fixed in 9.0.104
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.76; fixed in 9.0.104
- tomcat (Bitnami): affected from 9.0.76; fixed in 9.0.104, 10.1.40, 11.0.6
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat:tomcat-coyote (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat:tomcat-coyote (Maven): affected from 11.0.0-M2; fixed in 11.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31650/ (Markdown: https://insights.sbomify.com/CVE-2025-31650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31650
- OSV: https://osv.dev/vulnerability/CVE-2025-31650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31650/
Summaries are generated and may contain mistakes; the official description above is the record.
