# CVE-2025-31651: Apache Tomcat: Bypass of rules in Rewrite Valve

> Attackers can bypass security constraints enforced by specific Rewrite Valve rules in Apache Tomcat via crafted requests.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** BIT-tomcat-2025-31651, CLEANSTART-2026-EV68545, CLSA-2025-1750780819, CLSA-2025-1750785145, CLSA-2025-1752087582, CLSA-2025-1761576180, CLSA-2025-1764716872, CLSA-2026-1769701085, CLSA-2026-1770768569, CLSA-2026-1786542969, CLSA-2026-1793134796, DEBIAN-CVE-2025-31651, GHSA-ff77-26x5-69cr, ROOT-APP-MAVEN-CVE-2025-31651, SUSE-SU-2025:01882-1, UBUNTU-CVE-2025-31651

## What is CVE-2025-31651?

CVE-2025-31651 is a critical vulnerability in Apache Tomcat, published on 28 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. For a subset of unlikely rewrite rule configurations, it was possible 
for a specially crafted request to bypass some rewrite rules. If those 
rewrite rules effectively enforced security constraints, those 
constraints could be bypassed.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.5, from 10.1.0-M1 through 10.1.39, from 9.0.0.M1 through 9.0.102.
The following versions were EOL at the time the CVE was created but are 
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions 
may also be affected.

Users are recommended to upgrade to version [FIXED_VERSION], which fixes the issue.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2025-31651?

17 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core, tomcat and org.apache.tomcat:tomcat-catalina. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.76 | 9.0.104 |
| `org.apache.tomcat.embed:tomcat-embed-core` | Maven | From 9.0.76 | 9.0.104 |
| `tomcat` | Bitnami | All versions | 9.0.104, 10.1.40, 11.0.6 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 10.1.10 | 10.1.40 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 11.0.0-M2 | 11.0.6 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 8.5.0 to 8.5.100 | None |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.76 | 9.0.104 |
| `org.apache.tomcat:tomcat-catalina` | Maven | From 9.0.76 | 9.0.104 |
| `tomcat` | SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 9.0.36-3.142.1 |

Products: Apache Tomcat.

## How do I fix CVE-2025-31651?

Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 10.1.40, 11.0.6 or 9.0.104.

## Is CVE-2025-31651 being exploited?

There is no known exploitation of CVE-2025-31651 in the wild and no public exploit code.

Public exploit code:

- CVE-2025-31651 PoC (github_poc): https://github.com/gregk4sec/CVE-2025-31651-o
- https://github.com/gregk4sec/cve-2025-31651 (github_poc): https://github.com/gregk4sec/cve-2025-31651

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31651 and fix it if it is affected.

What it is: CVE-2025-31651 is a critical vulnerability in Apache Tomcat, published on 28 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31651 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M2; fixed in 11.0.6
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 11.0.0-M2; fixed in 11.0.6
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 8.5.0 up to 8.5.100; no fix listed
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.76; fixed in 9.0.104
- org.apache.tomcat.embed:tomcat-embed-core (Maven): affected from 9.0.76; fixed in 9.0.104
- tomcat (Bitnami): affected all versions; fixed in 9.0.104, 10.1.40, 11.0.6
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat:tomcat-catalina (Maven): affected from 10.1.10; fixed in 10.1.40
- org.apache.tomcat:tomcat-catalina (Maven): affected from 11.0.0-M2; fixed in 11.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31651/ (Markdown: https://insights.sbomify.com/CVE-2025-31651/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31651
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31651
- OSV: https://osv.dev/vulnerability/CVE-2025-31651

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31651/
Summaries are generated and may contain mistakes; the official description above is the record.
