{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.poi:poi-ooxml. It affects 2 products.","exploited":"There is no known exploitation of CVE-2025-31672 in the wild and no public exploit code.","fix":"Upgrade org.apache.poi:poi-ooxml to 5.4.0 or later.","what":"CVE-2025-31672 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-31672 and fix it if it is affected.\n\nWhat it is: CVE-2025-31672 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-31672 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.poi:poi-ooxml (Maven): affected all versions; fixed in 5.4.0\n- org.apache.poi:poi-ooxml (Maven): affected all versions; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31672/ (Markdown: https://insights.sbomify.com/CVE-2025-31672/index.md)","id":"CVE-2025-31672","markdown":"https://insights.sbomify.com/CVE-2025-31672/index.md","name":"CVE-2025-31672","record":{"aliases":["CLSA-2026-1778028244","DEBIAN-CVE-2025-31672","ECHO-35f1-f238-ebcf","GHSA-gmg8-593g-7mv3","MINI-37g9-jcvf-8jv8","MINI-c9p6-6jwc-24c3","MINI-w6ww-72w7-jw96","UBUNTU-CVE-2025-31672"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Java Office file library","requires_auth":"none","summary":"Attackers can craft OOXML files with duplicate zip entries to cause inconsistent data reading, potentially exposing unexpected information to applications using Apache POI.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"poi","vendor":"apache"},{"product":"active_iq_unified_manager","vendor":"netapp"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry.\nThis issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file.\nUsers are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read  https://poi.apache.org/security.html  for recommendations about how to use the POI libraries securely.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing","id":"CVE-2025-31672","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"netapp:active_iq_unified_manager","products":["netapp:active_iq_unified_manager"],"type":"information_disclosure","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Drupal core - Moderately critical - Access bypass - SA-CORE-2025-002","id":"CVE-2025-31673"},"packages":[{"ecosystem":"Maven","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi-ooxml","purl":null,"source":"GHSA-gmg8-593g-7mv3"},{"ecosystem":"Maven","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.poi:poi-ooxml","purl":"pkg:maven/org.apache.poi/poi-ooxml","source":"GHSA-gmg8-593g-7mv3"}],"prev":{"headline":"Privilege escalation in Intel(R) Battery Life Diagnostic Tool","id":"CVE-2025-31655"},"products":["Apache POI"],"published":"2025-04-09","related":[{"cvss_score":7.5,"headline":"Denial of Service in Apache POI","id":"CVE-2017-12626","kev_date_added":null,"published":"2018-01-29"},{"cvss_score":5.5,"headline":"A carefully crafted TNEF file can cause an out of memory exception","id":"CVE-2022-26336","kev_date_added":null,"published":"2022-03-04"},{"cvss_score":5.5,"headline":"Improper Restriction of XML External Entity Reference in Apache POI","id":"CVE-2019-12415","kev_date_added":null,"published":"2019-10-23"},{"cvss_score":5.5,"headline":"Improper Restriction of Recursive Entity References in DTDs in Apache POI","id":"CVE-2017-5644","kev_date_added":null,"published":"2017-03-24"},{"cvss_score":5.5,"headline":"Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability","id":"CVE-2016-5000","kev_date_added":null,"published":"2016-08-05"},{"cvss_score":5,"headline":"Loop with Unreachable Exit Condition in Apache POI","id":"CVE-2014-9527","kev_date_added":null,"published":"2015-01-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-23","vendors":["Apache Software Foundation"]},"summary":"Attackers can craft OOXML files with duplicate zip entries to cause inconsistent data reading, potentially exposing unexpected information to applications using Apache POI.","url":"https://insights.sbomify.com/CVE-2025-31672/"}