# CVE-2025-31672: Apache POI OOXML Vulnerable to Improper Input Validation in OOXML File Parsing

> Attackers can craft OOXML files with duplicate zip entries to cause inconsistent data reading, potentially exposing unexpected information to applications using Apache POI.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Apr 2025
- **Updated:** 23 May 2025
- **Also known as:** CLSA-2026-1778028244, DEBIAN-CVE-2025-31672, ECHO-35f1-f238-ebcf, GHSA-gmg8-593g-7mv3, MINI-37g9-jcvf-8jv8, MINI-c9p6-6jwc-24c3, MINI-w6ww-72w7-jw96, UBUNTU-CVE-2025-31672

## What is CVE-2025-31672?

CVE-2025-31672 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry.
This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file.
Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read  https://poi.apache.org/security.html  for recommendations about how to use the POI libraries securely.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-31672?

2 open source packages ship an affected version, including org.apache.poi:poi-ooxml. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.poi:poi-ooxml` | Maven | All versions | 5.4.0 |
| `org.apache.poi:poi-ooxml` | Maven | All versions | 5.4.0 |

Products: Apache Poi, Netapp Active Iq Unified Manager.

## How do I fix CVE-2025-31672?

Upgrade org.apache.poi:poi-ooxml to 5.4.0 or later.

## Is CVE-2025-31672 being exploited?

There is no known exploitation of CVE-2025-31672 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2017-12626](https://insights.sbomify.com/CVE-2017-12626/): Denial of Service in Apache POI (high 7.5)
- [CVE-2022-26336](https://insights.sbomify.com/CVE-2022-26336/): A carefully crafted TNEF file can cause an out of memory exception (medium 5.5)
- [CVE-2019-12415](https://insights.sbomify.com/CVE-2019-12415/): Improper Restriction of XML External Entity Reference in Apache POI (medium 5.5)
- [CVE-2017-5644](https://insights.sbomify.com/CVE-2017-5644/): Improper Restriction of Recursive Entity References in DTDs in Apache POI (medium 5.5)
- [CVE-2016-5000](https://insights.sbomify.com/CVE-2016-5000/): Apache POI's XLSX2CSV Example XML External Entity (XXE) Vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31672 and fix it if it is affected.

What it is: CVE-2025-31672 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 9 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31672 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.poi:poi-ooxml (Maven): affected all versions; fixed in 5.4.0
- org.apache.poi:poi-ooxml (Maven): affected all versions; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31672/ (Markdown: https://insights.sbomify.com/CVE-2025-31672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31672
- OSV: https://osv.dev/vulnerability/CVE-2025-31672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31672/
Summaries are generated and may contain mistakes; the official description above is the record.
