CVE-2025-31674 Drupal core - Moderately critical - Gadget Chain - SA-CORE-2025-003

High 7.5 Published Updated

Drupal core allows object injection via gadget chains, potentially enabling remote code execution for attackers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-31674?

CVE-2025-31674 is a high-severity unsafe deserialization vulnerability in Drupal Drupal, published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improperly Controlled Modification of Dynamically-Determined Object Attributes vulnerability in Drupal Drupal core allows Object Injection.This issue affects Drupal core: from 8.0.0 before 10.3.13, from 10.4.0 before 10.4.3, from 11.0.0 before 11.0.12, from 11.1.0 before 11.1.3.

Weakness: CWE-913, CWE-915

Which versions are affected by CVE-2025-31674?

10 open source packages ship an affected version, including drupal/core and drupal. It affects 1 product.

PackageAffectedFixed in
drupal/core PackagistFrom 10.4.010.4.3
drupal/core PackagistFrom 10.4.010.4.3
drupal/core PackagistFrom 11.0.011.0.12
drupal/core PackagistFrom 11.0.011.0.12
drupal/core PackagistFrom 11.1.011.1.3
drupal/core PackagistFrom 11.1.011.1.3
4 more packages
drupal/core PackagistFrom 8.0.010.3.13, 10.4.3, 11.0.12, 11.1.3
drupal/core PackagistFrom 8.0.010.3.13
drupal/core PackagistFrom 8.0.010.3.13
drupal BitnamiFrom 8.0.010.4.3, 11.1.3

Products include Drupal Drupal.

How do I fix CVE-2025-31674?

Upgrade drupal/core to a fixed version for your release line: 10.4.3, 11.0.12, 11.1.3 or 10.3.13.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-31674 being exploited?

There is no known exploitation of CVE-2025-31674 in the wild and no public exploit code.

All Drupal Drupal vulnerabilities

Sources

Also known as BIT-drupal-2025-31674, DRUPAL-CORE-2025-003, GHSA-2qph-q8xw-gv7q.

Is CVE-2025-31674 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free