# CVE-2025-31678: AI (Artificial Intelligence) - Moderately critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-004

> Attackers can bypass authorization to access restricted information in the Drupal AI module via forceful browsing.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 29 Apr 2025
- **Also known as:** DRUPAL-CONTRIB-2025-004, GHSA-c8q6-wp7v-46r9

## What is CVE-2025-31678?

CVE-2025-31678 is a high-severity missing authorization vulnerability in Drupal AI (Artificial Intelligence), published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing Authorization vulnerability in Drupal AI (Artificial Intelligence) allows Forceful Browsing.This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-31678?

2 open source packages ship an affected version, including drupal/ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/ai` | Packagist | All versions | 1.0.3 |
| `drupal/ai` | Packagist | All versions | 1.0.3 |
| `drupal/ai` | Packagist:https://packages.drupal.org/8 | All versions | 1.0.3 |

Products: Artificial Intelligence Project Artificial Intelligence.

## How do I fix CVE-2025-31678?

Upgrade drupal/ai to 1.0.3 or later.

## Is CVE-2025-31678 being exploited?

There is no known exploitation of CVE-2025-31678 in the wild and no public exploit code.

## Other vulnerabilities in Drupal AI (Artificial Intelligence)

- [CVE-2025-31677](https://insights.sbomify.com/CVE-2025-31677/): AI (Artificial Intelligence) - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-003 (high 8.8)
- [CVE-2026-3573](https://insights.sbomify.com/CVE-2026-3573/): AI (Artificial Intelligence) - Moderately critical - Information Disclosure - SA-CONTRIB-2026-028 (high 7.5)
- [CVE-2025-31692](https://insights.sbomify.com/CVE-2025-31692/): AI (Artificial Intelligence) - Critical - Remote Code Execution - SA-CONTRIB-2025-021 (high 7.5)
- [CVE-2025-31693](https://insights.sbomify.com/CVE-2025-31693/): AI (Artificial Intelligence) - Moderately critical - Gadget Chain - SA-CONTRIB-2025-022 (medium 6.6)
- [CVE-2026-13234](https://insights.sbomify.com/CVE-2026-13234/): Cross-site scripting in AI (Artificial Intelligence) (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31678 and fix it if it is affected.

What it is: CVE-2025-31678 is a high-severity missing authorization vulnerability in Drupal AI (Artificial Intelligence), published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31678 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/ai (Packagist): affected all versions; fixed in 1.0.3
- drupal/ai (Packagist): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31678/ (Markdown: https://insights.sbomify.com/CVE-2025-31678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31678
- OSV: https://osv.dev/vulnerability/CVE-2025-31678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31678/
Summaries are generated and may contain mistakes; the official description above is the record.
