{"answers":{"affected":"4 open source packages ship an affected version, including drupal/google_tag. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-31682 in the wild and no public exploit code.","fix":"Upgrade drupal/google_tag to a fixed version for your release line: 1.8.0 or 2.0.8.","what":"CVE-2025-31682 is a medium-severity cross-site scripting vulnerability in Drupal Google Tag, published on 31 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-31682 and fix it if it is affected.\n\nWhat it is: CVE-2025-31682 is a medium-severity cross-site scripting vulnerability in Drupal Google Tag, published on 31 Mar 2025. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-31682 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/google_tag (Packagist): affected all versions; fixed in 1.8.0\n- drupal/google_tag (Packagist): affected all versions; fixed in 1.8.0\n- drupal/google_tag (Packagist): affected from 2.0.0; fixed in 2.0.8\n- drupal/google_tag (Packagist): affected from 2.0.0; fixed in 2.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31682/ (Markdown: https://insights.sbomify.com/CVE-2025-31682/index.md)","id":"CVE-2025-31682","markdown":"https://insights.sbomify.com/CVE-2025-31682/index.md","name":"CVE-2025-31682","record":{"aliases":["DRUPAL-CONTRIB-2025-011","GHSA-36vv-q5jv-94cj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Google Tag","requires_auth":"high_privilege","summary":"An attacker can inject malicious scripts into pages via the Google Tag module, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"google_tag","vendor":"google_tag_project"}],"cvss":{"score":4.8,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Google Tag allows Cross-Site Scripting (XSS).This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Google Tag - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-011","id":"CVE-2025-31682","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":5,"n_references":1,"next":{"headline":"Google Tag - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-012","id":"CVE-2025-31683"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"drupal/google_tag","purl":null,"source":"GHSA-36vv-q5jv-94cj"},{"ecosystem":"Packagist","fixed":["1.8.0"],"introduced":["0"],"last_affected":[],"package":"drupal/google_tag","purl":"pkg:composer/drupal/google_tag","source":"GHSA-36vv-q5jv-94cj"},{"ecosystem":"Packagist","fixed":["2.0.8"],"introduced":["2.0.0"],"last_affected":[],"package":"drupal/google_tag","purl":null,"source":"GHSA-36vv-q5jv-94cj"},{"ecosystem":"Packagist","fixed":["2.0.8"],"introduced":["2.0.0"],"last_affected":[],"package":"drupal/google_tag","purl":"pkg:composer/drupal/google_tag","source":"GHSA-36vv-q5jv-94cj"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.8.0","2.0.8"],"introduced":["0","2.0.0"],"last_affected":[],"package":"drupal/google_tag","purl":"pkg:composer/drupal/google_tag?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-011"}],"prev":{"headline":"Authenticator Login - Critical - Access bypass - SA-CONTRIB-2025-009","id":"CVE-2025-31681"},"products":["Google Tag"],"published":"2025-03-31","related":[{"cvss_score":6.8,"headline":"Google Tag - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-012","id":"CVE-2025-31683","kev_date_added":null,"published":"2025-03-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into pages via the Google Tag module, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2025-31682/"}