CVE-2025-31683 Google Tag - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-012
Attackers can trick authenticated users into performing unwanted actions in the Drupal Google Tag module via CSRF.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-31683?
CVE-2025-31683 is a medium-severity vulnerability in Drupal Google Tag, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Google Tag allows Cross Site Request Forgery.This issue affects Google Tag: from 0.0.0 before 1.8.0, from 2.0.0 before 2.0.8.
Weakness: CWE-352
Which versions are affected by CVE-2025-31683?
4 open source packages ship an affected version, including drupal/google_tag. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/google_tag Packagist | All versions | 1.8.0 |
drupal/google_tag Packagist | All versions | 1.8.0 |
drupal/google_tag Packagist | From 2.0.0 | 2.0.8 |
drupal/google_tag Packagist | From 2.0.0 | 2.0.8 |
Linux distribution packages (1)
drupal/google_tag Packagist:https://packages.drupal.org/8 | All versions | 1.8.0, 2.0.8 |
Products include Google Tag Project Google Tag.
How do I fix CVE-2025-31683?
Upgrade drupal/google_tag to a fixed version for your release line: 1.8.0 or 2.0.8.
Is CVE-2025-31683 being exploited?
There is no known exploitation of CVE-2025-31683 in the wild and no public exploit code.
Other vulnerabilities in Drupal Google Tag
Sources
Also known as DRUPAL-CONTRIB-2025-012, GHSA-qchr-8m24-7v66.