CVE-2025-31686 Open Social - Less critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-015

High 8.1 Published Updated

Attackers can bypass authorization to access restricted information in Drupal Open Social via forceful browsing.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-31686?

CVE-2025-31686 is a high-severity missing authorization vulnerability in Drupal Open Social, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing.This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.

Weakness: CWE-862

Which versions are affected by CVE-2025-31686?

4 open source packages ship an affected version, including goalgorilla/open_social. It affects 1 product.

PackageAffectedFixed in
goalgorilla/open_social PackagistAll versions12.3.11
goalgorilla/open_social PackagistAll versions12.3.11
goalgorilla/open_social PackagistFrom 12.4.012.4.10
goalgorilla/open_social PackagistFrom 12.4.012.4.10

Products include Getopensocial Open Social.

How do I fix CVE-2025-31686?

Upgrade goalgorilla/open_social to a fixed version for your release line: 12.3.11 or 12.4.10.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-31686 being exploited?

There is no known exploitation of CVE-2025-31686 in the wild and no public exploit code.

Sources

Also known as GHSA-m9w8-wxvp-c9gv.

Is CVE-2025-31686 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free