{"answers":{"affected":"2 open source packages ship an affected version, including drupal/spamspan. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-31687 in the wild and no public exploit code.","fix":"Upgrade drupal/spamspan to 3.2.1 or later.","what":"CVE-2025-31687 is a medium-severity cross-site scripting vulnerability in Drupal SpamSpan filter, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-31687 and fix it if it is affected.\n\nWhat it is: CVE-2025-31687 is a medium-severity cross-site scripting vulnerability in Drupal SpamSpan filter, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-31687 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/spamspan (Packagist): affected all versions; fixed in 3.2.1\n- drupal/spamspan (Packagist): affected all versions; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31687/ (Markdown: https://insights.sbomify.com/CVE-2025-31687/index.md)","id":"CVE-2025-31687","markdown":"https://insights.sbomify.com/CVE-2025-31687/index.md","name":"CVE-2025-31687","record":{"aliases":["CLSA-2026-1788971215","CLSA-2026-1788973403","DRUPAL-CONTRIB-2025-016","GHSA-8r2q-865v-wm8j"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal SpamSpan filter","requires_auth":"none","summary":"An attacker can inject malicious scripts into web pages via the SpamSpan filter, potentially compromising user sessions or data.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"spamspan_filter","vendor":"drowl"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal SpamSpan filter allows Cross-Site Scripting (XSS).This issue affects SpamSpan filter: from 0.0.0 before 3.2.1.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SpamSpan filter - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-016","id":"CVE-2025-31687","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Configuration Split - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-017","id":"CVE-2025-31688"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"drupal/spamspan","purl":null,"source":"GHSA-8r2q-865v-wm8j"},{"ecosystem":"Packagist","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"drupal/spamspan","purl":"pkg:composer/drupal/spamspan","source":"GHSA-8r2q-865v-wm8j"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["3.2.1"],"introduced":["0"],"last_affected":[],"package":"drupal/spamspan","purl":"pkg:composer/drupal/spamspan?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-016"}],"prev":{"headline":"Open Social - Less critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-015","id":"CVE-2025-31686"},"products":["SpamSpan filter"],"published":"2025-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages via the SpamSpan filter, potentially compromising user sessions or data.","url":"https://insights.sbomify.com/CVE-2025-31687/"}