CVE-2025-31688 Configuration Split - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-017
Attackers can trick authenticated users into performing unwanted actions in the Configuration Split module, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-31688?
CVE-2025-31688 is a medium-severity vulnerability in Drupal Configuration Split, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal Configuration Split allows Cross Site Request Forgery.This issue affects Configuration Split: from 0.0.0 before 1.10.0, from 2.0.0 before 2.0.2.
Weakness: CWE-352
Which versions are affected by CVE-2025-31688?
4 open source packages ship an affected version, including drupal/config_split. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/config_split Packagist | All versions | 1.10.0 |
drupal/config_split Packagist | All versions | 1.10.0 |
drupal/config_split Packagist | From 2.0.0 | 2.0.2 |
drupal/config_split Packagist | From 2.0.0 | 2.0.2 |
Linux distribution packages (1)
drupal/config_split Packagist:https://packages.drupal.org/8 | All versions | 1.10.0, 2.0.2 |
Products include Nuvole Configuration Split.
How do I fix CVE-2025-31688?
Upgrade drupal/config_split to a fixed version for your release line: 1.10.0 or 2.0.2.
Is CVE-2025-31688 being exploited?
There is no known exploitation of CVE-2025-31688 in the wild and no public exploit code.
Sources
Also known as DRUPAL-CONTRIB-2025-017, GHSA-qq45-cqhg-jwx5.