# CVE-2025-31688: Configuration Split - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-017

> Attackers can trick authenticated users into performing unwanted actions in the Configuration Split module, requiring an upgrade to mitigate.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 29 Apr 2025
- **Also known as:** DRUPAL-CONTRIB-2025-017, GHSA-qq45-cqhg-jwx5

## What is CVE-2025-31688?

CVE-2025-31688 is a medium-severity vulnerability in Drupal Configuration Split, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery (CSRF) vulnerability in Drupal Configuration Split allows Cross Site Request Forgery.This issue affects Configuration Split: from 0.0.0 before 1.10.0, from 2.0.0 before 2.0.2.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-31688?

4 open source packages ship an affected version, including drupal/config_split. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/config_split` | Packagist | All versions | 1.10.0 |
| `drupal/config_split` | Packagist | All versions | 1.10.0 |
| `drupal/config_split` | Packagist | From 2.0.0 | 2.0.2 |
| `drupal/config_split` | Packagist | From 2.0.0 | 2.0.2 |
| `drupal/config_split` | Packagist:https://packages.drupal.org/8 | All versions | 1.10.0, 2.0.2 |

Products: Nuvole Configuration Split.

## How do I fix CVE-2025-31688?

Upgrade drupal/config_split to a fixed version for your release line: 1.10.0 or 2.0.2.

## Is CVE-2025-31688 being exploited?

There is no known exploitation of CVE-2025-31688 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31688 and fix it if it is affected.

What it is: CVE-2025-31688 is a medium-severity vulnerability in Drupal Configuration Split, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-31688 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/config_split (Packagist): affected all versions; fixed in 1.10.0
- drupal/config_split (Packagist): affected all versions; fixed in 1.10.0
- drupal/config_split (Packagist): affected from 2.0.0; fixed in 2.0.2
- drupal/config_split (Packagist): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31688/ (Markdown: https://insights.sbomify.com/CVE-2025-31688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31688
- OSV: https://osv.dev/vulnerability/CVE-2025-31688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31688/
Summaries are generated and may contain mistakes; the official description above is the record.
