CVE-2025-31689 General Data Protection Regulation - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-018
Attackers can trick authenticated users into performing unwanted actions in the Drupal GDPR module, bypassing security controls.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-31689?
CVE-2025-31689 is a high-severity vulnerability in Drupal General Data Protection Regulation, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-Site Request Forgery (CSRF) vulnerability in Drupal General Data Protection Regulation allows Cross Site Request Forgery.This issue affects General Data Protection Regulation: from 0.0.0 before 3.0.1, from 3.1.0 before 3.1.2.
Weakness: CWE-352
Which versions are affected by CVE-2025-31689?
4 open source packages ship an affected version, including drupal/gdpr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
drupal/gdpr Packagist | All versions | 3.0.1 |
drupal/gdpr Packagist | All versions | 3.0.1 |
drupal/gdpr Packagist | From 3.1.0 | 3.1.2 |
drupal/gdpr Packagist | From 3.1.0 | 3.1.2 |
Linux distribution packages (1)
drupal/gdpr Packagist:https://packages.drupal.org/8 | All versions | 3.0.1, 3.1.2 |
Products include General Data Protection Regulation Project General Data Protection Regulation.
How do I fix CVE-2025-31689?
Upgrade drupal/gdpr to a fixed version for your release line: 3.0.1 or 3.1.2.
Is CVE-2025-31689 being exploited?
There is no known exploitation of CVE-2025-31689 in the wild and no public exploit code.
Sources
Also known as CLSA-2026-1788971869, CLSA-2026-1788972898, CLSA-2026-1790249402, DRUPAL-CONTRIB-2025-018, GHSA-jv6r-mj9p-9xff.