CVE-2025-3169 Projeqtor saveAttachment.php unrestricted upload

Low 2.3 Published Updated

Attackers can upload malicious files to Projeqtor, potentially executing code if the attachment directory is improperly configured within the web root.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-3169?

CVE-2025-3169 is a low-severity vulnerability in Projeqtor, published on 3 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was found in Projeqtor up to 12.0.2. It has been rated as critical. Affected by this issue is some unknown functionality of the file /tool/saveAttachment.php. The manipulation of the argument attachmentFiles leads to unrestricted upload. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 12.0.3 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains, that "this vulnerability can be exploited only on not securely installed instances, as it is adviced during product install: attachment directory should be out of web reach, so that even if executable file can be uploaded, it cannot be executed through the web."

Weakness: CWE-434, CWE-284

Which versions are affected by CVE-2025-3169?

How do I fix CVE-2025-3169?

No fix has been published for CVE-2025-3169 yet. Limit exposure of the affected software until one is available.

Is CVE-2025-3169 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3169 exists.

Sources

Also known as GHSA-pxcm-3fhq-q738.

Is CVE-2025-3169 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free