{"answers":{"affected":"2 open source packages ship an affected version, including drupal/cache_utility. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-31690 in the wild and no public exploit code.","fix":"Upgrade drupal/cache_utility to 1.2.1 or later.","what":"CVE-2025-31690 is a high-severity vulnerability in Drupal Cache Utility, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-31690 and fix it if it is affected.\n\nWhat it is: CVE-2025-31690 is a high-severity vulnerability in Drupal Cache Utility, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-31690 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/cache_utility (Packagist): affected all versions; fixed in 1.2.1\n- drupal/cache_utility (Packagist): affected all versions; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31690/ (Markdown: https://insights.sbomify.com/CVE-2025-31690/index.md)","id":"CVE-2025-31690","markdown":"https://insights.sbomify.com/CVE-2025-31690/index.md","name":"CVE-2025-31690","record":{"aliases":["DRUPAL-CONTRIB-2025-019","GHSA-ccc9-jgj7-hxc7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Cache Utility","requires_auth":"none","summary":"Attackers can trick authenticated users into performing unwanted actions via CSRF in the Drupal Cache Utility module.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"cache_utility","vendor":"cache_utility_project"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cross-Site Request Forgery (CSRF) vulnerability in Drupal Cache Utility allows Cross Site Request Forgery.This issue affects Cache Utility: from 0.0.0 before 1.2.1.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cache Utility - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-019","id":"CVE-2025-31690","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"OAuth2 Server - Moderately critical - Access bypass - SA-CONTRIB-2025-020","id":"CVE-2025-31691"},"packages":[{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"drupal/cache_utility","purl":null,"source":"GHSA-ccc9-jgj7-hxc7"},{"ecosystem":"Packagist","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"drupal/cache_utility","purl":"pkg:composer/drupal/cache_utility","source":"GHSA-ccc9-jgj7-hxc7"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.2.1"],"introduced":["0"],"last_affected":[],"package":"drupal/cache_utility","purl":"pkg:composer/drupal/cache_utility?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-019"}],"prev":{"headline":"General Data Protection Regulation - Moderately critical - Cross Site Request Forgery - SA-CONTRIB-2025-018","id":"CVE-2025-31689"},"products":["Cache Utility"],"published":"2025-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["Drupal"]},"summary":"Attackers can trick authenticated users into performing unwanted actions via CSRF in the Drupal Cache Utility module.","url":"https://insights.sbomify.com/CVE-2025-31690/"}