# CVE-2025-31691: OAuth2 Server - Moderately critical - Access bypass - SA-CONTRIB-2025-020

> Attackers can bypass authorization checks in the Drupal OAuth2 Server module to access restricted resources without proper permissions.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 29 Apr 2025
- **Also known as:** DRUPAL-CONTRIB-2025-020, GHSA-4f8q-mwgc-3mwc

## What is CVE-2025-31691?

CVE-2025-31691 is a critical missing authorization vulnerability in Drupal OAuth2 Server, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing Authorization vulnerability in Drupal OAuth2 Server allows Forceful Browsing.This issue affects OAuth2 Server: from 0.0.0 before 2.1.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-31691?

2 open source packages ship an affected version, including drupal/oauth2_server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/oauth2_server` | Packagist | All versions | 2.1.0 |
| `drupal/oauth2_server` | Packagist | All versions | 2.1.0 |
| `drupal/oauth2_server` | Packagist:https://packages.drupal.org/8 | All versions | 2.1.0 |

Products: Oauth2 Server Project Oauth2 Server.

## How do I fix CVE-2025-31691?

Upgrade drupal/oauth2_server to 2.1.0 or later.

## Is CVE-2025-31691 being exploited?

There is no known exploitation of CVE-2025-31691 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31691 and fix it if it is affected.

What it is: CVE-2025-31691 is a critical missing authorization vulnerability in Drupal OAuth2 Server, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31691 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/oauth2_server (Packagist): affected all versions; fixed in 2.1.0
- drupal/oauth2_server (Packagist): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31691/ (Markdown: https://insights.sbomify.com/CVE-2025-31691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31691
- OSV: https://osv.dev/vulnerability/CVE-2025-31691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31691/
Summaries are generated and may contain mistakes; the official description above is the record.
