# CVE-2025-31692: AI (Artificial Intelligence) - Critical - Remote Code Execution - SA-CONTRIB-2025-021

> Attackers can execute arbitrary OS commands via the Drupal AI module, requiring an upgrade to the latest version.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Mar 2025
- **Updated:** 3 Apr 2025
- **Also known as:** DRUPAL-CONTRIB-2025-021, GHSA-pwjq-fx3v-8f9r

## What is CVE-2025-31692?

CVE-2025-31692 is a high-severity command injection vulnerability in Drupal AI (Artificial Intelligence), published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection.This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-31692?

2 open source packages ship an affected version, including drupal/ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/ai` | Packagist | All versions | 1.0.5 |
| `drupal/ai` | Packagist | All versions | 1.0.5 |
| `drupal/ai` | Packagist:https://packages.drupal.org/8 | All versions | 1.0.5 |

Products: Artificial Intelligence Project Artificial Intelligence.

## How do I fix CVE-2025-31692?

Upgrade drupal/ai to 1.0.5 or later.

## Is CVE-2025-31692 being exploited?

There is no known exploitation of CVE-2025-31692 in the wild and no public exploit code.

## Other vulnerabilities in Drupal AI (Artificial Intelligence)

- [CVE-2025-31677](https://insights.sbomify.com/CVE-2025-31677/): AI (Artificial Intelligence) - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-003 (high 8.8)
- [CVE-2025-31678](https://insights.sbomify.com/CVE-2025-31678/): AI (Artificial Intelligence) - Moderately critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-004 (high 8.2)
- [CVE-2026-3573](https://insights.sbomify.com/CVE-2026-3573/): AI (Artificial Intelligence) - Moderately critical - Information Disclosure - SA-CONTRIB-2026-028 (high 7.5)
- [CVE-2025-31693](https://insights.sbomify.com/CVE-2025-31693/): AI (Artificial Intelligence) - Moderately critical - Gadget Chain - SA-CONTRIB-2025-022 (medium 6.6)
- [CVE-2026-13234](https://insights.sbomify.com/CVE-2026-13234/): Cross-site scripting in AI (Artificial Intelligence) (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31692 and fix it if it is affected.

What it is: CVE-2025-31692 is a high-severity command injection vulnerability in Drupal AI (Artificial Intelligence), published on 31 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31692 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/ai (Packagist): affected all versions; fixed in 1.0.5
- drupal/ai (Packagist): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31692/ (Markdown: https://insights.sbomify.com/CVE-2025-31692/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31692
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31692
- OSV: https://osv.dev/vulnerability/CVE-2025-31692

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31692/
Summaries are generated and may contain mistakes; the official description above is the record.
