{"answers":{"affected":"2 open source packages ship an affected version, including drupal/ai. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-31693 in the wild and no public exploit code.","fix":"Upgrade drupal/ai to 1.0.5 or later.","what":"CVE-2025-31693 is a medium-severity command injection vulnerability in Drupal AI (Artificial Intelligence), published on 31 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-31693 and fix it if it is affected.\n\nWhat it is: CVE-2025-31693 is a medium-severity command injection vulnerability in Drupal AI (Artificial Intelligence), published on 31 Mar 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-31693 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/ai (Packagist): affected all versions; fixed in 1.0.5\n- drupal/ai (Packagist): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31693/ (Markdown: https://insights.sbomify.com/CVE-2025-31693/index.md)","id":"CVE-2025-31693","markdown":"https://insights.sbomify.com/CVE-2025-31693/index.md","name":"CVE-2025-31693","record":{"aliases":["DRUPAL-CONTRIB-2025-022","GHSA-vx9m-rfxq-gr74"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal AI module","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary OS commands via the Drupal AI module, requiring an upgrade to the latest version.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"artificial_intelligence","vendor":"artificial_intelligence_project"}],"cvss":{"score":6.6,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection.This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AI (Artificial Intelligence) - Moderately critical - Gadget Chain - SA-CONTRIB-2025-022","id":"CVE-2025-31693","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Two-factor Authentication (TFA) - Moderately critical - Access bypass - SA-CONTRIB-2025-023","id":"CVE-2025-31694"},"packages":[{"ecosystem":"Packagist","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"drupal/ai","purl":null,"source":"GHSA-vx9m-rfxq-gr74"},{"ecosystem":"Packagist","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"drupal/ai","purl":"pkg:composer/drupal/ai","source":"GHSA-vx9m-rfxq-gr74"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"drupal/ai","purl":"pkg:composer/drupal/ai?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-022"}],"prev":{"headline":"AI (Artificial Intelligence) - Critical - Remote Code Execution - SA-CONTRIB-2025-021","id":"CVE-2025-31692"},"products":["AI (Artificial Intelligence)"],"published":"2025-03-31","related":[{"cvss_score":8.8,"headline":"AI (Artificial Intelligence) - Critical - Cross Site Request Forgery - SA-CONTRIB-2025-003","id":"CVE-2025-31677","kev_date_added":null,"published":"2025-03-31"},{"cvss_score":8.2,"headline":"AI (Artificial Intelligence) - Moderately critical - Access bypass, Information Disclosure - SA-CONTRIB-2025-004","id":"CVE-2025-31678","kev_date_added":null,"published":"2025-03-31"},{"cvss_score":7.5,"headline":"AI (Artificial Intelligence) - Moderately critical - Information Disclosure - SA-CONTRIB-2026-028","id":"CVE-2026-3573","kev_date_added":null,"published":"2026-03-26"},{"cvss_score":7.5,"headline":"AI (Artificial Intelligence) - Critical - Remote Code Execution - SA-CONTRIB-2025-021","id":"CVE-2025-31692","kev_date_added":null,"published":"2025-03-31"},{"cvss_score":6.1,"headline":"Cross-site scripting in AI (Artificial Intelligence)","id":"CVE-2026-13234","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":6.1,"headline":"Cross-site scripting in n/a","id":"CVE-2015-9501","kev_date_added":null,"published":"2019-10-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-03","vendors":["Drupal"]},"summary":"Attackers can execute arbitrary OS commands via the Drupal AI module, requiring an upgrade to the latest version.","url":"https://insights.sbomify.com/CVE-2025-31693/"}