{"answers":{"affected":"2 open source packages ship an affected version, including drupal/formatter_suite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-31697 in the wild and no public exploit code.","fix":"Upgrade drupal/formatter_suite to 2.1.0 or later.","what":"CVE-2025-31697 is a medium-severity cross-site scripting vulnerability in Drupal Formatter Suite, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-31697 and fix it if it is affected.\n\nWhat it is: CVE-2025-31697 is a medium-severity cross-site scripting vulnerability in Drupal Formatter Suite, published on 31 Mar 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-31697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/formatter_suite (Packagist): affected all versions; fixed in 2.1.0\n- drupal/formatter_suite (Packagist): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31697/ (Markdown: https://insights.sbomify.com/CVE-2025-31697/index.md)","id":"CVE-2025-31697","markdown":"https://insights.sbomify.com/CVE-2025-31697/index.md","name":"CVE-2025-31697","record":{"aliases":["DRUPAL-CONTRIB-2025-026","GHSA-5r66-vgc7-2mm3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal Formatter Suite","requires_auth":"none","summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Formatter Suite module, potentially leading to session hijacking or data theft.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"drupal","cpe":[{"product":"formatter_suite","vendor":"formatter_suite_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Formatter Suite allows Cross-Site Scripting (XSS).This issue affects Formatter Suite: from 0.0.0 before 2.1.0.","ecosystems":["Packagist","Packagist:https://packages.drupal.org/8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Formatter Suite - Moderately critical - Cross site scripting - SA-CONTRIB-2025-026","id":"CVE-2025-31697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Apache Traffic Server: Client IP address from PROXY protocol is not used for ACL","id":"CVE-2025-31698"},"packages":[{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"drupal/formatter_suite","purl":null,"source":"GHSA-5r66-vgc7-2mm3"},{"ecosystem":"Packagist","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"drupal/formatter_suite","purl":"pkg:composer/drupal/formatter_suite","source":"GHSA-5r66-vgc7-2mm3"},{"ecosystem":"Packagist:https://packages.drupal.org/8","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"drupal/formatter_suite","purl":"pkg:composer/drupal/formatter_suite?repository_url=https:%2F%2Fpackages.drupal.org%2F8","source":"DRUPAL-CONTRIB-2025-026"}],"prev":{"headline":"RapiDoc OAS Field Formatter - Moderately critical - Cross site scripting - SA-CONTRIB-2025-025","id":"CVE-2025-31696"},"products":["Formatter Suite"],"published":"2025-03-31","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"MIT","name":"Drupal","prefix":"DRUPAL"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["Drupal"]},"summary":"An attacker can inject malicious scripts into web pages viewed by other users via the Formatter Suite module, potentially leading to session hijacking or data theft.","url":"https://insights.sbomify.com/CVE-2025-31697/"}