CVE-2025-31698 Apache Traffic Server: Client IP address from PROXY protocol is not used for ACL

High 7.5 Published Updated

Attackers can bypass IP-based access controls in Apache Traffic Server when PROXY protocol is enabled, allowing unauthorized access to protected resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-31698?

CVE-2025-31698 is a high-severity missing authorization vulnerability in Apache Traffic Server, published on 19 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

ACL configured in ip_allow.config or remap.config does not use IP addresses that are provided by PROXY protocol.

Users can use a new setting (proxy.config.acl.subjects) to choose which IP addresses to use for the ACL if Apache Traffic Server is configured to accept PROXY protocol.  This issue affects undefined: from 10.0.0 through 10.0.6, from 9.0.0 through 9.2.10.

Users are recommended to upgrade to version 9.2.11 or 10.0.6, which fixes the issue.

Weakness: CWE-284

Which versions are affected by CVE-2025-31698?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2025-31698?

Upgrade to a fixed version.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-31698 being exploited?

There is no known exploitation of CVE-2025-31698 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2025-31698, GHSA-v2wx-jg5q-pj8q, UBUNTU-CVE-2025-31698.

Is CVE-2025-31698 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free