# CVE-2025-31699: Apache Traffic Server: Origin connection still owed a request body is reused, enabling request smuggling


- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:L/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** DEBIAN-CVE-2025-31699, GHSA-4h97-h3mf-j6w7, UBUNTU-CVE-2025-31699

## What is CVE-2025-31699?

CVE-2025-31699 is a critical vulnerability in Apache Traffic Server, published on 21 Oct 2026. 

### Official description

Apache Traffic Server can return an origin connection to the shared pool while the origin is still waiting on a request body the client declared but never fully sent, including when the client used Expect: 100-continue. The origin then reads a later request on that connection as leftover body data, which lets an attacker smuggle requests past ATS access controls, disrupt other users' requests, or poison the cache.

This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.15, from 10.0.0 through 10.1.4, 10.2.0.

Users are recommended to upgrade to version 9.2.16, 10.1.5, or 10.2.1, which fix the issue.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2025-31699?


## How do I fix CVE-2025-31699?

No fix has been published for CVE-2025-31699 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-31699 being exploited?

There is no known exploitation of CVE-2025-31699 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31699 and fix it if it is affected.

What it is: CVE-2025-31699 is a critical vulnerability in Apache Traffic Server, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2025-31699 in the wild and no public exploit code.

Affected product: Apache Traffic Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31699/ (Markdown: https://insights.sbomify.com/CVE-2025-31699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31699
- OSV: https://osv.dev/vulnerability/CVE-2025-31699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31699/
Summaries are generated and may contain mistakes; the official description above is the record.
