# CVE-2025-31721: Jenkins Missing Permission Check

> Attackers with limited permissions can copy agents to access encrypted secrets due to a missing permission check in Jenkins.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2025
- **Updated:** 2 Apr 2025
- **Also known as:** BIT-jenkins-2025-31721, GHSA-wr6w-jxg7-qpfh, MINI-c55r-cpw3-6555, MINI-cgxg-wjvq-h7r5

## What is CVE-2025-31721?

CVE-2025-31721 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 2 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins 2.503 and earlier, LTS 2.492.2 and earlier allows attackers with Computer/Create permission but without Computer/Configure permission to copy an agent, gaining access to encrypted secrets in its configuration.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-31721?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.492.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.492.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.500 | 2.504 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.500 | 2.504 |
| `jenkins` | Bitnami | All versions | 2.492.3, 2.504.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2025-31721?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.492.3 or 2.504.

## Is CVE-2025-31721 being exploited?

There is no known exploitation of CVE-2025-31721 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31721 and fix it if it is affected.

What it is: CVE-2025-31721 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 2 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-31721 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.492.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.492.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.500; fixed in 2.504
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.500; fixed in 2.504
- jenkins (Bitnami): affected all versions; fixed in 2.492.3, 2.504.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31721/ (Markdown: https://insights.sbomify.com/CVE-2025-31721/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31721
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31721
- OSV: https://osv.dev/vulnerability/CVE-2025-31721

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31721/
Summaries are generated and may contain mistakes; the official description above is the record.
