{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:simple-queue. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-31723 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:simple-queue to 1.4.7 or later.","what":"CVE-2025-31723 is a medium-severity vulnerability in Jenkins Simple Queue Plugin, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-31723 and fix it if it is affected.\n\nWhat it is: CVE-2025-31723 is a medium-severity vulnerability in Jenkins Simple Queue Plugin, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-31723 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:simple-queue (Maven): affected all versions; fixed in 1.4.7\n- io.jenkins.plugins:simple-queue (Maven): affected all versions; fixed in 1.4.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-31723/ (Markdown: https://insights.sbomify.com/CVE-2025-31723/index.md)","id":"CVE-2025-31723","markdown":"https://insights.sbomify.com/CVE-2025-31723/index.md","name":"CVE-2025-31723","record":{"aliases":["GHSA-hcfh-qjcp-34q9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Simple Queue Plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to change and reset the build queue order in Jenkins Simple Queue Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"simple_queue","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Simple Queue Plugin 1.4.6 and earlier allows attackers to change and reset the build queue order.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Simple Queue Plugin Cross-Site Request Forgery (CSRF)","id":"CVE-2025-31723","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Cadence vManager Plugin Stores Verisium Manager vAPI keys Unencrypted","id":"CVE-2025-31724"},"packages":[{"ecosystem":"Maven","fixed":["1.4.7"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:simple-queue","purl":null,"source":"GHSA-hcfh-qjcp-34q9"},{"ecosystem":"Maven","fixed":["1.4.7"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:simple-queue","purl":"pkg:maven/io.jenkins.plugins/simple-queue","source":"GHSA-hcfh-qjcp-34q9"}],"prev":{"headline":"Jenkins Templating Engine Plugin Vulnerable to Arbitrary Code Execution","id":"CVE-2025-31722"},"products":["Jenkins Simple Queue Plugin"],"published":"2025-04-02","related":[{"cvss_score":8,"headline":"Jenkins Simple Queue Plugin has stored cross-site scripting (XSS) vulnerability","id":"CVE-2024-54003","kev_date_added":null,"published":"2024-11-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-02","vendors":["Jenkins Project"]},"summary":"Attackers can exploit CSRF to change and reset the build queue order in Jenkins Simple Queue Plugin.","url":"https://insights.sbomify.com/CVE-2025-31723/"}