# CVE-2025-31723: Jenkins Simple Queue Plugin Cross-Site Request Forgery (CSRF)

> Attackers can exploit CSRF to change and reset the build queue order in Jenkins Simple Queue Plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2025
- **Updated:** 2 Apr 2025
- **Also known as:** GHSA-hcfh-qjcp-34q9

## What is CVE-2025-31723?

CVE-2025-31723 is a medium-severity vulnerability in Jenkins Simple Queue Plugin, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins Simple Queue Plugin 1.4.6 and earlier allows attackers to change and reset the build queue order.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-31723?

2 open source packages ship an affected version, including io.jenkins.plugins:simple-queue. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:simple-queue` | Maven | All versions | 1.4.7 |
| `io.jenkins.plugins:simple-queue` | Maven | All versions | 1.4.7 |

Products: Jenkins Simple Queue.

## How do I fix CVE-2025-31723?

Upgrade io.jenkins.plugins:simple-queue to 1.4.7 or later.

## Is CVE-2025-31723 being exploited?

There is no known exploitation of CVE-2025-31723 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Simple Queue Plugin

- [CVE-2024-54003](https://insights.sbomify.com/CVE-2024-54003/): Jenkins Simple Queue Plugin has stored cross-site scripting (XSS) vulnerability (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-31723 and fix it if it is affected.

What it is: CVE-2025-31723 is a medium-severity vulnerability in Jenkins Simple Queue Plugin, published on 2 Apr 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-31723 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:simple-queue (Maven): affected all versions; fixed in 1.4.7
- io.jenkins.plugins:simple-queue (Maven): affected all versions; fixed in 1.4.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-31723/ (Markdown: https://insights.sbomify.com/CVE-2025-31723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-31723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-31723
- OSV: https://osv.dev/vulnerability/CVE-2025-31723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-31723/
Summaries are generated and may contain mistakes; the official description above is the record.
