{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3199 exists.","fix":"No fix has been published for CVE-2025-3199 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-3199 is a medium-severity missing authorization vulnerability in ageerle ruoyi-ai, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-3199 and fix it if it is affected.\n\nWhat it is: CVE-2025-3199 is a medium-severity missing authorization vulnerability in ageerle ruoyi-ai, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3199 exists.\n\nAffected product: ageerle ruoyi-ai. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-3199/ (Markdown: https://insights.sbomify.com/CVE-2025-3199/index.md)","id":"CVE-2025-3199","markdown":"https://insights.sbomify.com/CVE-2025-3199/index.md","name":"CVE-2025-3199","record":{"aliases":["GHSA-w9j2-68r5-mpp4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"RuoYi AI application","requires_auth":"none","summary":"Attackers can bypass authorization checks in the SysModelController API, potentially accessing unauthorized system model functionalities.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ruoyi_ai","vendor":"pandarobot"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"},{"id":"CWE-266","name":"Incorrect Privilege Assignment"}],"description":"A vulnerability was found in ageerle ruoyi-ai up to 2.0.1 and classified as critical. Affected by this issue is some unknown functionality of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysModelController.java of the component API Interface. The manipulation leads to improper authorization. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.2 is able to address this issue. The name of the patch is c0daf641fb25b244591b7a6c3affa35c69d321fe. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"ageerle ruoyi-ai API Interface SysModelController.java improper authorization","id":"CVE-2025-3199","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":0,"n_references":8,"next":{"headline":"Com-Server Exposed via Weak TLS","id":"CVE-2025-3200"},"packages":[],"prev":{"headline":"GNU Binutils objdump bucomm.c display_info memory leak","id":"CVE-2025-3198"},"products":["ruoyi-ai"],"published":"2025-04-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-04","vendors":["ageerle"]},"summary":"Attackers can bypass authorization checks in the SysModelController API, potentially accessing unauthorized system model functionalities.","url":"https://insights.sbomify.com/CVE-2025-3199/"}