# CVE-2025-3199: ageerle ruoyi-ai API Interface SysModelController.java improper authorization

> Attackers can bypass authorization checks in the SysModelController API, potentially accessing unauthorized system model functionalities.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Apr 2025
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-w9j2-68r5-mpp4

## What is CVE-2025-3199?

CVE-2025-3199 is a medium-severity missing authorization vulnerability in ageerle ruoyi-ai, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in ageerle ruoyi-ai up to 2.0.1 and classified as critical. Affected by this issue is some unknown functionality of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysModelController.java of the component API Interface. The manipulation leads to improper authorization. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.2 is able to address this issue. The name of the patch is c0daf641fb25b244591b7a6c3affa35c69d321fe. It is recommended to upgrade the affected component.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-3199?

It affects 1 product.


Products: Pandarobot Ruoyi Ai.

## How do I fix CVE-2025-3199?

No fix has been published for CVE-2025-3199 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3199 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3199 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3199 and fix it if it is affected.

What it is: CVE-2025-3199 is a medium-severity missing authorization vulnerability in ageerle ruoyi-ai, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3199 exists.

Affected product: ageerle ruoyi-ai. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3199/ (Markdown: https://insights.sbomify.com/CVE-2025-3199/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3199
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3199
- OSV: https://osv.dev/vulnerability/CVE-2025-3199

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3199/
Summaries are generated and may contain mistakes; the official description above is the record.
