# CVE-2025-32013: Server-Side Request Forgery via LNURL Authentication Callback in LNbits Lightning Network Payment System

> Attackers can exploit SSRF in LNbits LNURL authentication to access internal network resources by manipulating callback URLs.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Apr 2025
- **Updated:** 7 Apr 2025
- **Also known as:** GHSA-qp8j-p87f-c8cc, PYSEC-2025-16

## What is CVE-2025-32013?

CVE-2025-32013 is a critical server-side request forgery vulnerability in lnbits, published on 6 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LNbits is a Lightning wallet and accounts system. A Server-Side Request Forgery (SSRF) vulnerability has been discovered in LNbits' LNURL authentication handling functionality. When processing LNURL authentication requests, the application accepts a callback URL parameter and makes an HTTP request to that URL using the httpx library with redirect following enabled. The application doesn't properly validate the callback URL, allowing attackers to specify internal network addresses and access internal resources.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-32013?

3 open source packages ship an affected version, including lnbits. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lnbits` | PyPI | All versions to 0.12.12 | None |
| `lnbits` | PyPI | All versions to 0.12.12 | None |
| `lnbits` | PyPI | All versions | 0.12.12 |

Products: Lnbits Lnbits.

## How do I fix CVE-2025-32013?

Upgrade lnbits to 0.12.12 or later.

## Is CVE-2025-32013 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32013 exists.

Public exploit code:

- Security Advisory and PoC for CVE-2025-32013 (github_poc): https://github.com/Mohith-T/CVE-2025-32013

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32013 and fix it if it is affected.

What it is: CVE-2025-32013 is a critical server-side request forgery vulnerability in lnbits, published on 6 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-32013 exists.

Affected packages and fixed versions:
- lnbits (PyPI): affected all versions up to 0.12.12; no fix listed
- lnbits (PyPI): affected all versions up to 0.12.12; no fix listed
- lnbits (PyPI): affected all versions; fixed in 0.12.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32013/ (Markdown: https://insights.sbomify.com/CVE-2025-32013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32013
- OSV: https://osv.dev/vulnerability/CVE-2025-32013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32013/
Summaries are generated and may contain mistakes; the official description above is the record.
