CVE-2025-32016 Microsoft Identity Web Exposes Client Secrets and Certificate Information in Service Logs
Microsoft Identity Web library may expose client secrets and certificate details in service logs, requiring an upgrade to secure sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-32016?
CVE-2025-32016 is a medium-severity vulnerability in AzureAD microsoft-identity-web, published on 9 Apr 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Microsoft Identity Web is a library which contains a set of reusable classes used in conjunction with ASP.NET Core for integrating with the Microsoft identity platform (formerly Azure AD v2.0 endpoint) and AAD B2C. This vulnerability affects confidential client applications, including daemons, web apps, and web APIs. Under specific circumstances, sensitive information such as client secrets or certificate details may be exposed in the service logs of these applications. Service logs are intended to be handled securely. Service logs generated at the information level or credential descriptions containing local file paths with passwords, Base64 encoded values, or Client secret. Additionally, logs of services using Base64 encoded certificates or certificate paths with password credential descriptions are also affected if the certificates are invalid or expired, regardless of the log level. Note that these credentials are not usable due to their invalid or expired status. To mitigate this vulnerability, update to Microsoft.Identity.Web 3.8.2 or Microsoft.Identity.Abstractions 9.0.0.
Weakness: CWE-532
Which versions are affected by CVE-2025-32016?
4 open source packages ship an affected version, including Microsoft.Identity.Abstractions and Microsoft.Identity.Web.
| Package | Affected | Fixed in |
|---|---|---|
Microsoft.Identity.Abstractions NuGet | From 7.1.0 | 9.0.0 |
Microsoft.Identity.Abstractions NuGet | From 7.1.0 | 9.0.0 |
Microsoft.Identity.Web NuGet | From 3.2.0 | 3.8.2 |
Microsoft.Identity.Web NuGet | From 3.2.0 | 3.8.2 |
How do I fix CVE-2025-32016?
Upgrade Microsoft.Identity.Abstractions to 9.0.0 or later.
Is CVE-2025-32016 being exploited?
There is no known exploitation of CVE-2025-32016 in the wild and no public exploit code.
Sources
Also known as GHSA-rpq8-q44m-2rpg.