# CVE-2025-32018: Arbitrary file write from Cursor Agent through a prompt injection from malicious @Docs

> An attacker can trick the AI agent into writing files outside the workspace via prompt injection, though user review mitigates risk.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 8 Apr 2025
- **Updated:** 8 Apr 2025

## What is CVE-2025-32018?

CVE-2025-32018 is a high-severity path traversal vulnerability in getcursor cursor, published on 8 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cursor is a code editor built for programming with AI. In versions 0.45.0 through 0.48.6, the Cursor app introduced a regression affecting the set of file paths the Cursor Agent is permitted to modify automatically. Under specific conditions, the agent could be prompted, either directly by the user or via maliciously crafted context, to automatically write to files outside of the opened workspace. This behavior required deliberate prompting, making successful exploitation highly impractical in real-world scenarios. Furthermore, the edited file was still displayed in the UI as usual for user review, making it unlikely for the edit to go unnoticed by the user. This vulnerability is fixed in 0.48.7.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-32018?


## How do I fix CVE-2025-32018?

No fix has been published for CVE-2025-32018 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-32018 being exploited?

There is no known exploitation of CVE-2025-32018 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32018 and fix it if it is affected.

What it is: CVE-2025-32018 is a high-severity path traversal vulnerability in getcursor cursor, published on 8 Apr 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32018 in the wild and no public exploit code.

Affected product: getcursor cursor. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32018/ (Markdown: https://insights.sbomify.com/CVE-2025-32018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32018
- OSV: https://osv.dev/vulnerability/CVE-2025-32018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32018/
Summaries are generated and may contain mistakes; the official description above is the record.
