CVE-2025-32019 Harbor's repository description page allows for XSS

Medium 4.1 Published Updated

Attackers can inject malicious scripts via the repository description markdown field, potentially compromising user sessions in Harbor registries.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-32019?

CVE-2025-32019 is a medium-severity cross-site scripting vulnerability in goharbor harbor, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Harbor is an open source trusted cloud native registry project that stores, signs, and scans content. Versions 2.11.2 and below, as well as versions 2.12.0-rc1 and 2.13.0-rc1, contain a vulnerability where the markdown field in the info tab page can be exploited to inject XSS code. This is fixed in versions 2.11.3 and 2.12.3.

Weakness: CWE-79

Which versions are affected by CVE-2025-32019?

12 open source packages ship an affected version, including github.com/goharbor/harbor and harbor.

PackageAffectedFixed in
github.com/goharbor/harbor GoAll versionsNone
github.com/goharbor/harbor GoAll versions2.4.0-rc1.0.20250421072404-a13a16383a41
github.com/goharbor/harbor GoAll versions2.4.0-rc1.0.20250421072404-a13a16383a41
github.com/goharbor/harbor GoFrom 2.12.0-rc12.12.4-rc1
github.com/goharbor/harbor GoFrom 2.12.0-rc12.12.4-rc1
github.com/goharbor/harbor GoFrom 2.12.0-rc1+incompatible2.12.4-rc1+incompatible
6 more packages
github.com/goharbor/harbor GoFrom 2.13.0-rc12.13.1-rc1
github.com/goharbor/harbor GoFrom 2.13.0-rc12.13.1-rc1
github.com/goharbor/harbor GoFrom 2.13.0-rc1+incompatible2.13.1-rc1+incompatible
github.com/goharbor/harbor GoFrom 2.4.0-rc1.1 to 2.11.2None
github.com/goharbor/harbor GoFrom 2.4.0-rc1.1 to 2.11.2None
harbor BitnamiAll versions2.11.3

How do I fix CVE-2025-32019?

Upgrade github.com/goharbor/harbor to a fixed version for your release line: 2.4.0-rc1.0.20250421072404-a13a16383a41, 2.12.4-rc1, 2.12.4-rc1+incompatible or 2.13.1-rc1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-32019 being exploited?

There is no known exploitation of CVE-2025-32019 in the wild and no public exploit code.

Sources

Also known as BIT-harbor-2025-32019, GHSA-f9vc-vf3r-pqqq, GO-2025-3825.

Is CVE-2025-32019 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free