# CVE-2025-32019: Harbor's repository description page allows for XSS

> Attackers can inject malicious scripts via the repository description markdown field, potentially compromising user sessions in Harbor registries.

- **Severity:** Medium 4.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2025
- **Updated:** 23 Jul 2025
- **Also known as:** BIT-harbor-2025-32019, GHSA-f9vc-vf3r-pqqq, GO-2025-3825

## What is CVE-2025-32019?

CVE-2025-32019 is a medium-severity cross-site scripting vulnerability in goharbor harbor, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Harbor is an open source trusted cloud native registry project that stores, signs, and scans content. Versions 2.11.2 and below, as well as versions 2.12.0-rc1 and 2.13.0-rc1, contain a vulnerability where the markdown field in the info tab page can be exploited to inject XSS code. This is fixed in versions 2.11.3 and 2.12.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-32019?

12 open source packages ship an affected version, including github.com/goharbor/harbor and harbor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/goharbor/harbor` | Go | All versions | None |
| `github.com/goharbor/harbor` | Go | All versions | 2.4.0-rc1.0.20250421072404-a13a16383a41 |
| `github.com/goharbor/harbor` | Go | All versions | 2.4.0-rc1.0.20250421072404-a13a16383a41 |
| `github.com/goharbor/harbor` | Go | From 2.12.0-rc1 | 2.12.4-rc1 |
| `github.com/goharbor/harbor` | Go | From 2.12.0-rc1 | 2.12.4-rc1 |
| `github.com/goharbor/harbor` | Go | From 2.12.0-rc1+incompatible | 2.12.4-rc1+incompatible |
| `github.com/goharbor/harbor` | Go | From 2.13.0-rc1 | 2.13.1-rc1 |
| `github.com/goharbor/harbor` | Go | From 2.13.0-rc1 | 2.13.1-rc1 |
| `github.com/goharbor/harbor` | Go | From 2.13.0-rc1+incompatible | 2.13.1-rc1+incompatible |
| `github.com/goharbor/harbor` | Go | From 2.4.0-rc1.1 to 2.11.2 | None |
| `github.com/goharbor/harbor` | Go | From 2.4.0-rc1.1 to 2.11.2 | None |
| `harbor` | Bitnami | All versions | 2.11.3 |

## How do I fix CVE-2025-32019?

Upgrade github.com/goharbor/harbor to a fixed version for your release line: 2.4.0-rc1.0.20250421072404-a13a16383a41, 2.12.4-rc1, 2.12.4-rc1+incompatible or 2.13.1-rc1.

## Is CVE-2025-32019 being exploited?

There is no known exploitation of CVE-2025-32019 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32019 and fix it if it is affected.

What it is: CVE-2025-32019 is a medium-severity cross-site scripting vulnerability in goharbor harbor, published on 23 Jul 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-32019 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/goharbor/harbor (Go): affected all versions; no fix listed
- github.com/goharbor/harbor (Go): affected all versions; fixed in 2.4.0-rc1.0.20250421072404-a13a16383a41
- github.com/goharbor/harbor (Go): affected all versions; fixed in 2.4.0-rc1.0.20250421072404-a13a16383a41
- github.com/goharbor/harbor (Go): affected from 2.12.0-rc1; fixed in 2.12.4-rc1
- github.com/goharbor/harbor (Go): affected from 2.12.0-rc1; fixed in 2.12.4-rc1
- github.com/goharbor/harbor (Go): affected from 2.12.0-rc1+incompatible; fixed in 2.12.4-rc1+incompatible
- github.com/goharbor/harbor (Go): affected from 2.13.0-rc1; fixed in 2.13.1-rc1
- github.com/goharbor/harbor (Go): affected from 2.13.0-rc1; fixed in 2.13.1-rc1
- github.com/goharbor/harbor (Go): affected from 2.13.0-rc1+incompatible; fixed in 2.13.1-rc1+incompatible
- github.com/goharbor/harbor (Go): affected from 2.4.0-rc1.1 up to 2.11.2; no fix listed
- github.com/goharbor/harbor (Go): affected from 2.4.0-rc1.1 up to 2.11.2; no fix listed
- harbor (Bitnami): affected all versions; fixed in 2.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32019/ (Markdown: https://insights.sbomify.com/CVE-2025-32019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32019
- OSV: https://osv.dev/vulnerability/CVE-2025-32019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32019/
Summaries are generated and may contain mistakes; the official description above is the record.
