# CVE-2025-3202: ageerle ruoyi-ai SysNoticeController.java improper authorization

> Remote attackers can bypass authorization checks in the SysNoticeController to access or modify system notices without proper permissions.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Apr 2025
- **Updated:** 4 Apr 2025
- **Also known as:** GHSA-vf4w-gg7r-x8mw

## What is CVE-2025-3202?

CVE-2025-3202 is a medium-severity missing authorization vulnerability in ageerle ruoyi-ai, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability classified as critical has been found in ageerle ruoyi-ai up to 2.0.0. Affected is an unknown function of the file ruoyi-modules/ruoyi-system/src/main/java/org/ruoyi/system/controller/system/SysNoticeController.java. The manipulation leads to improper authorization. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.0.1 is able to address this issue. The name of the patch is 6382e177bf90cc56ff70521842409e35c50df32d. It is recommended to upgrade the affected component.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-3202?

It affects 1 product.


Products: Ageerle Ruoyi-Ai.

## How do I fix CVE-2025-3202?

No fix has been published for CVE-2025-3202 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-3202 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3202 exists.

## Other vulnerabilities in ageerle ruoyi-ai

- [CVE-2025-6466](https://insights.sbomify.com/CVE-2025-6466/): ageerle ruoyi-ai SseServiceImpl.java upload unrestricted upload (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-3202 and fix it if it is affected.

What it is: CVE-2025-3202 is a medium-severity missing authorization vulnerability in ageerle ruoyi-ai, published on 4 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-3202 exists.

Affected product: ageerle ruoyi-ai. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-3202/ (Markdown: https://insights.sbomify.com/CVE-2025-3202/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-3202
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-3202
- OSV: https://osv.dev/vulnerability/CVE-2025-3202

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-3202/
Summaries are generated and may contain mistakes; the official description above is the record.
