# CVE-2025-32020: Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') in crud-query-parser

> SQL injection in crud-query-parser TypeORM adapter allows attackers to manipulate database queries when ordering is enabled without property filters.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2025
- **Updated:** 8 Apr 2025
- **Also known as:** GHSA-9r25-rp3p-h2w4

## What is CVE-2025-32020?

CVE-2025-32020 is a critical SQL injection vulnerability in Guichaguri crud-query-parser, published on 8 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The crud-query-parser library parses query parameters from HTTP requests and converts them to database queries. Improper neutralization of the order/sort parameter in the TypeORM adapter, which allows SQL injection. You are impacted by this vulnerability if you are using the TypeORM adapter, ordering is enabled and you have not set-up a property filter.  This vulnerability is fixed in 0.1.0.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-32020?

2 open source packages ship an affected version, including crud-query-parser.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crud-query-parser` | npm | All versions | 0.1.0 |
| `crud-query-parser` | npm | All versions | 0.1.0 |

## How do I fix CVE-2025-32020?

Upgrade crud-query-parser to 0.1.0 or later.

## Is CVE-2025-32020 being exploited?

There is no known exploitation of CVE-2025-32020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-32020 and fix it if it is affected.

What it is: CVE-2025-32020 is a critical SQL injection vulnerability in Guichaguri crud-query-parser, published on 8 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-32020 in the wild and no public exploit code.

Affected packages and fixed versions:
- crud-query-parser (npm): affected all versions; fixed in 0.1.0
- crud-query-parser (npm): affected all versions; fixed in 0.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-32020/ (Markdown: https://insights.sbomify.com/CVE-2025-32020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-32020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-32020
- OSV: https://osv.dev/vulnerability/CVE-2025-32020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-32020/
Summaries are generated and may contain mistakes; the official description above is the record.
